summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-07-28 14:21:48 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-07-28 14:21:48 +0000
commitbe856e9b3ea7090df0cbca74b7118bebc4e39a80 (patch)
tree9c5041a5c64cedf7dcdb873b28713ac49f6abf58 /dev-haskell
parentnew package (diff)
downloadhistorical-be856e9b3ea7090df0cbca74b7118bebc4e39a80.tar.gz
historical-be856e9b3ea7090df0cbca74b7118bebc4e39a80.tar.bz2
historical-be856e9b3ea7090df0cbca74b7118bebc4e39a80.zip
new package
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hugs98-graphics/Manifest3
-rw-r--r--dev-haskell/hugs98-graphics/files/digest-hugs98-graphics-2.0.41
-rw-r--r--dev-haskell/hugs98-graphics/hugs98-graphics-2.0.4.ebuild35
3 files changed, 38 insertions, 1 deletions
diff --git a/dev-haskell/hugs98-graphics/Manifest b/dev-haskell/hugs98-graphics/Manifest
index 996384462141..880f74633c17 100644
--- a/dev-haskell/hugs98-graphics/Manifest
+++ b/dev-haskell/hugs98-graphics/Manifest
@@ -1,2 +1,3 @@
-MD5 0944bf3bc698abae3395eaaf601ed4ab hugs98-graphics-2.0.4.ebuild 913
+MD5 c7d886ea31622134ff1661bea2deac0c hugs98-graphics-2.0.4.ebuild 1072
+MD5 91149bbf559181644d34233e31df664e ChangeLog 446
MD5 ae927af5a1aa8d4c1265a48e19dee697 files/digest-hugs98-graphics-2.0.4 70
diff --git a/dev-haskell/hugs98-graphics/files/digest-hugs98-graphics-2.0.4 b/dev-haskell/hugs98-graphics/files/digest-hugs98-graphics-2.0.4
new file mode 100644
index 000000000000..6825154b5d43
--- /dev/null
+++ b/dev-haskell/hugs98-graphics/files/digest-hugs98-graphics-2.0.4
@@ -0,0 +1 @@
+MD5 60da7bc8f3a2414778fe1e693ba54ab4 graphics-2.0.4.src.tar.gz 170252
diff --git a/dev-haskell/hugs98-graphics/hugs98-graphics-2.0.4.ebuild b/dev-haskell/hugs98-graphics/hugs98-graphics-2.0.4.ebuild
new file mode 100644
index 000000000000..5e70fd704ded
--- /dev/null
+++ b/dev-haskell/hugs98-graphics/hugs98-graphics-2.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hugs98-graphics/hugs98-graphics-2.0.4.ebuild,v 1.1 2003/07/28 14:21:34 kosmikus Exp $
+
+DESCRIPTION="Haskell Graphics Library for X"
+HOMEPAGE="http://cvs.haskell.org/Hugs/pages/downloading.htm"
+SRC_URI="http://cvs.haskell.org/Hugs/downloads/graphics-${PV}.src.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/glibc
+ dev-lang/hugs98
+ virtual/x11"
+S=${WORKDIR}/graphics-${PV}
+# where Hugs is installed
+HUGSDIR="/usr/lib/hugs"
+# where Hugs libraries get installed
+HUGSLIBDIR="${D}${HUGSDIR}/lib"
+
+src_compile() {
+ # the package does not use configure
+ make -C lib/x11 hugs_install=${HUGSDIR}
+}
+
+src_install() {
+ dodoc Install License Readme Version Version-2.0.4
+ # don't gzip dvi file
+ install -m0644 doc/Graphics.dvi "${D}usr/share/doc/${PF}"
+ # don't gzip demo file
+ install -m0644 demos/HelloWorld.hs "${D}usr/share/doc/${PF}"
+
+ mkdir -p ${HUGSLIBDIR}
+ cp -R lib/x11/* ${HUGSLIBDIR}
+}