summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-01-16 14:18:57 +0000
committerVlastimil Babka <caster@gentoo.org>2007-01-16 14:18:57 +0000
commit0a04f1ae3fa51a1547d8cc1a76cdccae5a1abaa3 (patch)
treeeaa969bd398bee31d029aaae9e033725b122b763 /dev-java/java-config
parentNew for 2007 (diff)
downloadhistorical-0a04f1ae3fa51a1547d8cc1a76cdccae5a1abaa3.tar.gz
historical-0a04f1ae3fa51a1547d8cc1a76cdccae5a1abaa3.tar.bz2
historical-0a04f1ae3fa51a1547d8cc1a76cdccae5a1abaa3.zip
Revbump to apply latest changes to java-config-2.profiled.csh (by grobian 3 days ago) for everyone: fix (t)csh syntax and avoid using an undefined variable, acked by Betelgeuse on irc.
Package-Manager: portage-2.1.2
Diffstat (limited to 'dev-java/java-config')
-rw-r--r--dev-java/java-config/ChangeLog10
-rw-r--r--dev-java/java-config/files/digest-java-config-2.0.31-r33
-rw-r--r--dev-java/java-config/java-config-2.0.31-r3.ebuild59
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-java/java-config/ChangeLog b/dev-java/java-config/ChangeLog
index ef5538d63815..68cfca4d0393 100644
--- a/dev-java/java-config/ChangeLog
+++ b/dev-java/java-config/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/java-config
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.137 2007/01/13 16:36:54 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.138 2007/01/16 14:18:57 caster Exp $
+
+*java-config-2.0.31-r3 (16 Jan 2007)
+
+ 16 Jan 2007; Vlastimil Babka <caster@gentoo.org>
+ -java-config-2.0.31-r2.ebuild, +java-config-2.0.31-r3.ebuild:
+ Revbump to apply latest changes to java-config-2.profiled.csh (by grobian 3
+ days ago) for everyone: fix (t)csh syntax and avoid using an undefined
+ variable, acked by Betelgeuse on irc.
*java-config-2.0.31-r2 (13 Jan 2007)
diff --git a/dev-java/java-config/files/digest-java-config-2.0.31-r3 b/dev-java/java-config/files/digest-java-config-2.0.31-r3
new file mode 100644
index 000000000000..393d9dbec4ef
--- /dev/null
+++ b/dev-java/java-config/files/digest-java-config-2.0.31-r3
@@ -0,0 +1,3 @@
+MD5 36b7893b20b9f4b6f0af6dd632703745 java-config-2.0.31.tar.bz2 17001
+RMD160 4b3d8362538b435a642312ee7289824d6662e309 java-config-2.0.31.tar.bz2 17001
+SHA256 314ec1783da8190d60e757aaef2af8eae7281c3c9754024e3e59643ce7a30752 java-config-2.0.31.tar.bz2 17001
diff --git a/dev-java/java-config/java-config-2.0.31-r3.ebuild b/dev-java/java-config/java-config-2.0.31-r3.ebuild
new file mode 100644
index 000000000000..6fa18acfc655
--- /dev/null
+++ b/dev-java/java-config/java-config-2.0.31-r3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.0.31-r3.ebuild,v 1.1 2007/01/16 14:18:57 caster Exp $
+
+inherit base distutils eutils
+
+DESCRIPTION="Java environment configuration tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+ dev-java/java-config-wrapper"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/java-config-2/config/
+ for i in alpha amd64 hppa ia64 ppc ppc64 sparc x86 x86-fbsd; do
+ if use ${i}; then
+ newins config/jdk-defaults-${i}.conf jdk-defaults.conf || die "arch config not found"
+ fi
+ done
+
+ for tool in $(< config/symlink-tools); do
+ dosym /usr/bin/run-java-tool /usr/bin/${tool}
+ done
+
+ # Install profile.d for setting JAVA_HOME
+ dodir /etc/profile.d
+ exeinto /etc/profile.d
+ newexe ${FILESDIR}/${PN}-${SLOT}.profiled.sh ${PN}-${SLOT}.sh || die "newexe failed"
+ newexe ${FILESDIR}/${PN}-${SLOT}.profiled.csh ${PN}-${SLOT}.csh || die "newexe failed"
+}
+
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/java-config-2/pym/java_config
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/java-config-2/pym/java_config
+
+ elog "The way Java is handled on Gentoo has been recently updated."
+ elog "If you have not done so already, you should follow the"
+ elog "instructions available at:"
+ elog "\thttp://www.gentoo.org/proj/en/java/java-upgrade.xml"
+ elog
+ elog "While we are moving towards the new Java system, we only allow"
+ elog "1.3 or 1.4 JDKs to be used with java-config-1 to ensure"
+ elog "backwards compatibility with the old system."
+ elog "For more details about this, please see:"
+ elog "\thttps://overlays.gentoo.org/proj/java/wiki/Why_We_Need_Java14"
+}