summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-16 17:42:34 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-16 17:42:34 +0000
commitc79ebad8f9d5608e516a9916f7bf951481c3a9bf (patch)
tree6e26809a1b9be56137c9d33572e2aa403a327817 /dev-java/java-getopt
parentold (diff)
downloadhistorical-c79ebad8f9d5608e516a9916f7bf951481c3a9bf.tar.gz
historical-c79ebad8f9d5608e516a9916f7bf951481c3a9bf.tar.bz2
historical-c79ebad8f9d5608e516a9916f7bf951481c3a9bf.zip
use java-pkg_dohtml instead of dohtml to also install the package-list in case of api docs: #50740
Diffstat (limited to 'dev-java/java-getopt')
-rw-r--r--dev-java/java-getopt/ChangeLog6
-rw-r--r--dev-java/java-getopt/java-getopt-1.0.9.ebuild14
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-java/java-getopt/ChangeLog b/dev-java/java-getopt/ChangeLog
index 4cdf499b1d79..c90cbffa113f 100644
--- a/dev-java/java-getopt/ChangeLog
+++ b/dev-java/java-getopt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/java-getopt
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/ChangeLog,v 1.6 2004/06/27 17:42:56 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/ChangeLog,v 1.7 2004/10/16 17:19:06 axxo Exp $
+
+ 16 Oct 2004; Thomas Matthijs <axxo@gentoo.org> java-getopt-1.0.9.ebuild:
+ use java-pkg_dohtml instead of dohtml to also install the package-list in
+ case of api docs: #50740
27 Jun 2004; Chris Aniszczyk <zx@gentoo.org> java-getopt-1.0.9.ebuild:
Marking stable on ppc
diff --git a/dev-java/java-getopt/java-getopt-1.0.9.ebuild b/dev-java/java-getopt/java-getopt-1.0.9.ebuild
index b5351e070fa1..fb4dfc19d509 100644
--- a/dev-java/java-getopt/java-getopt-1.0.9.ebuild
+++ b/dev-java/java-getopt/java-getopt-1.0.9.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/java-getopt-1.0.9.ebuild,v 1.7 2004/06/27 17:42:56 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/java-getopt-1.0.9.ebuild,v 1.8 2004/10/16 17:19:06 axxo Exp $
+
+inherit java-pkg
DESCRIPTION="Java command line option parser"
HOMEPAGE="http://www.urbanophile.com/arenn/hacking/download.html"
@@ -14,17 +16,13 @@ IUSE=""
S=${WORKDIR}
-src_unpack() {
- unpack ${P}.tar.gz
-}
-
src_compile() {
mv gnu/getopt/buildx.xml build.xml
- ant all
+ ant all || die "failed to build"
}
src_install () {
- dojar build/lib/gnu.getopt.jar
- dohtml build/api/* -r
+ java-pkg_dojar build/lib/gnu.getopt.jar
+ java-pkg_dohtml -r build/api/*
dodoc gnu/getopt/COPYING.LIB gnu/getopt/ChangeLog gnu/getopt/README
}