summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-01 00:05:24 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-01 00:05:24 +0000
commit0913489057f5b206d47ff2b621013bd89476707f (patch)
tree5b74e4f37b1e21f400e10ae6e171277e523dc319 /dev-lang/python/python-2.2.1-r4.ebuild
parentoops! forgot to ~ppc it! (diff)
downloadhistorical-0913489057f5b206d47ff2b621013bd89476707f.tar.gz
historical-0913489057f5b206d47ff2b621013bd89476707f.tar.bz2
historical-0913489057f5b206d47ff2b621013bd89476707f.zip
historical python ebuilds cleanup
Diffstat (limited to 'dev-lang/python/python-2.2.1-r4.ebuild')
-rw-r--r--dev-lang/python/python-2.2.1-r4.ebuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/dev-lang/python/python-2.2.1-r4.ebuild b/dev-lang/python/python-2.2.1-r4.ebuild
deleted file mode 100644
index 37aa4e9298cb..000000000000
--- a/dev-lang/python/python-2.2.1-r4.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r4.ebuild,v 1.8 2003/02/13 10:28:33 vapier Exp $
-
-IUSE="readline tcltk berkdb bootstrap"
-
-PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
-PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
-S=${WORKDIR}/Python-${PV}
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz"
-
-HOMEPAGE="http://www.python.org"
-LICENSE="PSF-2.2"
-KEYWORDS="x86 ppc sparc alpha"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )"
-if [ -z "`use build`" -a -z "`use bootstrap`" ]; then
- DEPEND="$DEPEND dev-libs/expat"
-fi
-RDEPEND="$DEPEND dev-python/python-fchksum"
-
-# The dev-python/python-fchksum RDEPEND is needed to that this python provides
-# the functionality expected from previous pythons.
-
-PROVIDE="virtual/python"
-
-SLOT="2.2"
-
-inherit flag-o-matic
-
-src_compile() {
- filter-flags -malign-double
- export OPT="$CFLAGS"
-
- # adjust makefile to install pydoc into ${D} correctly
- t=${S}/Makefile.pre.in
- cp $t $t.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-
- local myopts
- #if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]
- then
- myopts="--with-cxx=no"
- fi
-
- econf --with-fpectl \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
- $myopts || die
- emake || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
- rm "${D}/usr/bin/python"
- dosym python${PYVER_MAJOR} /usr/bin/python
- dosym python${PYVER_MAJOR}.${PYVER_MINOR} /usr/bin/python${PYVER_MAJOR}
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- newexe ${FILESDIR}/python-config-${PV} python-config
-
- # seems like the build do not install Makefile.pre.in anymore
- # it probably shouldn't - use DistUtils, people!
- insinto /usr/lib/python${PYVER}/config
- doins ${S}/Makefile.pre.in
-
- # While we're working on the config stuff... Let's fix the OPT var
- # so that it doesn't have any opts listed in it. Prevents the problem
- # with compiling things with conflicting opts later.
- mv \
- ${D}/usr/lib/python${PYVER}/config/Makefile \
- ${D}/usr/lib/python${PYVER}/config/Makefile.orig
- sed 's:^OPT=.*:OPT=-NDEBUG:' \
- < ${D}/usr/lib/python${PYVER}/config/Makefile.orig \
- > ${D}/usr/lib/python${PYVER}/config/Makefile
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- dodir /usr/lib/python${PYVER}/tools
- mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
- dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
- fi
-}