summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-03-05 11:34:44 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-03-05 11:34:44 +0000
commit2efad1b14a2372250b3dca0659f1e9d0692a8436 (patch)
tree40dfbbc41bd3b68bb46b00511349e1581fe1cea6 /dev-php/pecl-pam/pecl-pam-1.0.3.ebuild
parentRemoved older ebuilds (diff)
downloadhistorical-2efad1b14a2372250b3dca0659f1e9d0692a8436.tar.gz
historical-2efad1b14a2372250b3dca0659f1e9d0692a8436.tar.bz2
historical-2efad1b14a2372250b3dca0659f1e9d0692a8436.zip
Version bump
Package-Manager: portage-2.1.11.50/cvs/Linux x86_64 Manifest-Sign-Key: 0xC4A92BF5
Diffstat (limited to 'dev-php/pecl-pam/pecl-pam-1.0.3.ebuild')
-rw-r--r--dev-php/pecl-pam/pecl-pam-1.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/pecl-pam/pecl-pam-1.0.3.ebuild b/dev-php/pecl-pam/pecl-pam-1.0.3.ebuild
new file mode 100644
index 000000000000..ba1919605de7
--- /dev/null
+++ b/dev-php/pecl-pam/pecl-pam-1.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-pam/pecl-pam-1.0.3.ebuild,v 1.1 2013/03/05 11:34:40 olemarkus Exp $
+
+EAPI=5
+
+PHP_EXT_NAME="pam"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+inherit php-ext-pecl-r2 pam
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="This extension provides PAM (Pluggable Authentication Modules) integration."
+LICENSE="PHP-2.02"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ my_conf="--with-pam=/usr $(use_enable debug)"
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ pamd_mimic_system php auth account password
+ php-ext-pecl-r2_src_install
+}