summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-12 21:21:04 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-12 21:21:04 +0000
commit5fcb77a471e5677da9a1b9ec51c43a6354de8407 (patch)
treecc54e384a41420726daae09ed82fa849b110d7e0 /dev-python/docutils
parentDelete older ebuilds. (diff)
downloadhistorical-5fcb77a471e5677da9a1b9ec51c43a6354de8407.tar.gz
historical-5fcb77a471e5677da9a1b9ec51c43a6354de8407.tar.bz2
historical-5fcb77a471e5677da9a1b9ec51c43a6354de8407.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/docutils')
-rw-r--r--dev-python/docutils/Manifest2
-rw-r--r--dev-python/docutils/docutils-0.3.7.ebuild96
-rw-r--r--dev-python/docutils/docutils-0.4-r2.ebuild101
-rw-r--r--dev-python/docutils/docutils-0.4-r3.ebuild107
-rw-r--r--dev-python/docutils/files/50docutils-gentoo.el8
-rw-r--r--dev-python/docutils/files/docutils-0.4-python-2.5-fix.patch132
6 files changed, 1 insertions, 445 deletions
diff --git a/dev-python/docutils/Manifest b/dev-python/docutils/Manifest
index 3f4021945b47..e59c7f6403b1 100644
--- a/dev-python/docutils/Manifest
+++ b/dev-python/docutils/Manifest
@@ -4,5 +4,5 @@ DIST docutils-0.5.tar.gz 1271981 RMD160 3e8dfd2923528bbeac0ca33ccfe6f576c74f1886
DIST glep-0.4-r1.tbz2 4667 RMD160 bea44f2fe567422fd42bedebdf04cb6d984478ae SHA1 123516118f8bb2c75296a125702f4bf8f3ff1959 SHA256 d0b421869fb3437e96484687fd57f34d4f5cdd5a1fbdb2314f1474b1f9afa058
EBUILD docutils-0.5-r1.ebuild 3143 RMD160 0a2155152806ffbe8bef3235a30d14ce94374f60 SHA1 bf5e100a1e3d765d493428c58b7c744cb5c4aa51 SHA256 262e3a60cd4a2d3bfb18e3c7c21e1342f9cedfa3b2f459cb428377333d4a7f80
EBUILD docutils-0.5.ebuild 2852 RMD160 901e7b21d2afe155e55bcce9d73c3676f024597b SHA1 5650567da54fe7c71b39dddbba75d242d02dc571 SHA256 ab74fcff7c94ba6bc47fda9dfe4ce928d242bdb8c7163e67c6b7ebbf1402b6e2
-MISC ChangeLog 13936 RMD160 04030cca7386f7a8cb78a50a3cb34933949d39ac SHA1 a284d62d198b8799ec1208ab963b1bd0244424b1 SHA256 847183809dd80dc6af1177401c7a632996a790f6e1dbf5d82a8fbe91f421b668
+MISC ChangeLog 13939 RMD160 194017d9d9d9babb199297249cb2de56ccf3b1cf SHA1 b09a2796d80a97796f8eecd135e93bc85dc14545 SHA256 2df9c23f394ae80be56e0af5f46aee6e96a2d6a883659958a722e7afbd735a16
MISC metadata.xml 224 RMD160 37a2cf5db0ab817c0e2a1127e9cc4278bf88c904 SHA1 e2c1b45b839624cbc4bd949c8458d50dec01e7cb SHA256 0bb6bfd1577f4800009497c7813935f712ae6a44dbbdec1a903e79eaa5f21755
diff --git a/dev-python/docutils/docutils-0.3.7.ebuild b/dev-python/docutils/docutils-0.3.7.ebuild
deleted file mode 100644
index a253c3cb31e5..000000000000
--- a/dev-python/docutils/docutils-0.3.7.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.3.7.ebuild,v 1.20 2008/06/29 10:36:49 tove Exp $
-
-inherit distutils eutils elisp-common multilib
-
-DESCRIPTION="Set of python tools for processing plaintext docs into HTML, XML, etc."
-HOMEPAGE="http://docutils.sourceforge.net/"
-SRC_URI="mirror://sourceforge/docutils/${P}.tar.gz
- glep? ( mirror://gentoo/glep-${PV}.tbz2 )"
-
-LICENSE="public-domain PYTHON BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="glep emacs"
-DEPEND=">=dev-lang/python-2.2
- emacs? ( virtual/emacs )"
-
-SITEFILE=50docutils-gentoo.el
-
-GLEP_SRC=${WORKDIR}/glep-${PV}
-
-src_unpack() {
- unpack ${A}
- # simplified algorithm to select installing optparse and textwrap
- epatch "${FILESDIR}"/${P}-extramodules.patch
-}
-
-src_compile() {
- distutils_src_compile
-
- # Generate html docs from reStructured text sources
- PYTHONPATH=${S}/build/lib ${python} \
- tools/buildhtml.py --config=tools/docutils.conf
- if use emacs; then
- pushd tools/editors/emacs; elisp-compile *.el; popd
- fi
-}
-
-install_txt_doc() {
- local doc=${1}
- local dir="txt/$(dirname ${doc})"
- docinto ${dir}
- dodoc ${doc}
-}
-
-src_test() {
- cd "${S}"/test
- PYTHONPATH="${S}" ./alltests.py || die "alltests.py failed"
-}
-
-src_install() {
- DOCS="*.txt"
- distutils_src_install
- # Tools
- cd "${S}"/tools
- for tool in *.py
- do
- newbin ${tool} docutils-${tool}
- done
- # Docs
- cd "${S}"
- dohtml -r docs spec tools
- for doc in $(find docs spec tools -name '*.txt')
- do
- install_txt_doc $doc
- done
-
- # installing Gentoo GLEP tools. Uses versioned GLEP distribution
- if use glep
- then
- distutils_python_version
- newbin ${GLEP_SRC}/glep.py docutils-glep.py || die "newbin failed"
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/docutils/readers
- newins ${GLEP_SRC}/glepread.py glep.py || die "newins reader failed"
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/docutils/transforms
- newins ${GLEP_SRC}/glepstrans.py gleps.py || die "newins transform failed"
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/docutils/writers
- newins ${GLEP_SRC}/glep_htmlwrite.py glep_html.py || die "newins writer failed"
- fi
-
- if use emacs; then
- elisp-install ${PN} tools/editors/emacs/*.{elc,el}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- distutils_pkg_postrm
-}
diff --git a/dev-python/docutils/docutils-0.4-r2.ebuild b/dev-python/docutils/docutils-0.4-r2.ebuild
deleted file mode 100644
index 366640799c3a..000000000000
--- a/dev-python/docutils/docutils-0.4-r2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.4-r2.ebuild,v 1.13 2008/06/29 10:36:49 tove Exp $
-
-inherit distutils eutils multilib
-
-DESCRIPTION="Set of python tools for processing plaintext docs into HTML, XML, etc..."
-HOMEPAGE="http://docutils.sourceforge.net/"
-SRC_URI="mirror://sourceforge/docutils/${P}.tar.gz
- glep? ( mirror://gentoo/glep-${PV}-r1.tbz2 )"
-
-LICENSE="public-domain PYTHON BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="glep emacs"
-
-DEPEND=">=dev-lang/python-2.3"
-# Emacs support is in PDEPEND to avoid a dependency cycle (bug #183242)
-PDEPEND="emacs? ( >=app-emacs/rst-0.4 )"
-
-EMP=${PN}-0.3.7
-
-GLEP_SRC=${WORKDIR}/glep-${PV}-r1
-
-src_unpack() {
- unpack ${A}
- # simplified algorithm to select installing optparse and textwrap
- cd "${S}"
- epatch "${FILESDIR}"/${EMP}-extramodules.patch
- # Fix for Python 2.5 test (bug# 172557)
- epatch "${FILESDIR}"/${P}-python-2.5-fix.patch
-}
-
-src_compile() {
- distutils_src_compile
-
- # Generate html docs from reStructured text sources.
-
- # make roman.py available for the doc building process
- ln -s extras/roman.py
-
- pushd tools
-
- # Place html4css1.css in base directory. This makes sure the
- # generated reference to it is correct.
- cp ../docutils/writers/html4css1/html4css1.css ..
-
- PYTHONPATH=.. ${python} ./buildhtml.py --stylesheet-path=../html4css1.css --traceback .. \
- || die "buildhtml"
-
- popd
-
- # clean up after the doc building
- rm roman.py html4css1.css
-}
-
-install_txt_doc() {
- local doc=${1}
- local dir="txt/$(dirname ${doc})"
- docinto ${dir}
- dodoc ${doc}
-}
-
-src_test() {
- cd "${S}"/test
- PYTHONPATH="${S}" ./alltests.py || die "alltests.py failed"
-}
-
-src_install() {
- DOCS="*.txt"
- distutils_src_install
- # Tools
- cd "${S}"/tools
- for tool in *.py
- do
- dobin ${tool}
- done
- # Docs
- cd "${S}"
- dohtml -r docs tools
- # manually install the stylesheet file
- insinto /usr/share/doc/${PF}/html
- doins docutils/writers/html4css1/html4css1.css
- for doc in $(find docs tools -name '*.txt')
- do
- install_txt_doc $doc
- done
-
- # installing Gentoo GLEP tools. Uses versioned GLEP distribution
- if use glep
- then
- distutils_python_version
- dobin ${GLEP_SRC}/glep.py || die "newbin failed"
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/docutils/readers
- newins ${GLEP_SRC}/glepread.py glep.py || die "newins reader failed"
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/docutils/transforms
- newins ${GLEP_SRC}/glepstrans.py gleps.py || die "newins transform failed"
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/docutils/writers
- doins -r ${GLEP_SRC}/glep_html || die "doins writer failed"
- fi
-}
diff --git a/dev-python/docutils/docutils-0.4-r3.ebuild b/dev-python/docutils/docutils-0.4-r3.ebuild
deleted file mode 100644
index d762305ad0ae..000000000000
--- a/dev-python/docutils/docutils-0.4-r3.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/docutils/docutils-0.4-r3.ebuild,v 1.12 2008/07/18 11:01:14 aballier Exp $
-
-NEED_PYTHON=2.4
-
-inherit distutils eutils multilib
-
-DESCRIPTION="Set of python tools for processing plaintext docs into HTML, XML, etc..."
-HOMEPAGE="http://docutils.sourceforge.net/"
-SRC_URI="mirror://sourceforge/docutils/${P}.tar.gz
- glep? ( mirror://gentoo/glep-${PV}-r1.tbz2 )"
-
-LICENSE="public-domain PYTHON BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="glep emacs"
-
-DEPEND="dev-python/setuptools"
-# Emacs support is in PDEPEND to avoid a dependency cycle (bug #183242)
-PDEPEND="emacs? ( >=app-emacs/rst-0.4 )"
-
-EMP=${PN}-0.3.7
-
-GLEP_SRC=${WORKDIR}/glep-${PV}-r1
-
-src_unpack() {
- unpack ${A}
- # simplified algorithm to select installing optparse and textwrap
- cd "${S}"
- epatch "${FILESDIR}"/${EMP}-extramodules.patch
- # Fix for Python 2.5 test (bug# 172557)
- epatch "${FILESDIR}"/${P}-python-2.5-fix.patch
-
- sed -i \
- -e 's/from distutils.core/from setuptools/' \
- setup.py || die "sed failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- # Generate html docs from reStructured text sources.
-
- # make roman.py available for the doc building process
- ln -s extras/roman.py
-
- pushd tools
-
- # Place html4css1.css in base directory. This makes sure the
- # generated reference to it is correct.
- cp ../docutils/writers/html4css1/html4css1.css ..
-
- PYTHONPATH=.. ${python} ./buildhtml.py --stylesheet-path=../html4css1.css --traceback .. \
- || die "buildhtml"
-
- popd
-
- # clean up after the doc building
- rm roman.py html4css1.css
-}
-
-install_txt_doc() {
- local doc=${1}
- local dir="txt/$(dirname ${doc})"
- docinto ${dir}
- dodoc ${doc}
-}
-
-src_test() {
- cd "${S}"/test
- PYTHONPATH="${S}" ./alltests.py || die "alltests.py failed"
-}
-
-src_install() {
- DOCS="*.txt"
- distutils_src_install
- # Tools
- cd "${S}"/tools
- for tool in *.py
- do
- dobin ${tool}
- done
- # Docs
- cd "${S}"
- dohtml -r docs tools
- # manually install the stylesheet file
- insinto /usr/share/doc/${PF}/html
- doins docutils/writers/html4css1/html4css1.css
- for doc in $(find docs tools -name '*.txt')
- do
- install_txt_doc $doc
- done
-
- # installing Gentoo GLEP tools. Uses versioned GLEP distribution
- if use glep
- then
- distutils_python_version
- dobin ${GLEP_SRC}/glep.py || die "newbin failed"
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/docutils/readers
- newins ${GLEP_SRC}/glepread.py glep.py || die "newins reader failed"
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/docutils/transforms
- newins ${GLEP_SRC}/glepstrans.py gleps.py || die "newins transform failed"
- insinto /usr/$(get_libdir)/python${PYVER}/site-packages/docutils/writers
- doins -r ${GLEP_SRC}/glep_html || die "doins writer failed"
- fi
-}
diff --git a/dev-python/docutils/files/50docutils-gentoo.el b/dev-python/docutils/files/50docutils-gentoo.el
deleted file mode 100644
index e5a6bfc5bed8..000000000000
--- a/dev-python/docutils/files/50docutils-gentoo.el
+++ /dev/null
@@ -1,8 +0,0 @@
-
-;; site-lisp configuration for docutils
-
-(add-to-list 'load-path "@SITELISP@")
-(autoload 'rst-mode "rst-mode" "mode for editing reStructuredText documents" t)
-(setq auto-mode-alist
- (append '(("\\.rst$" . rst-mode)
- ("\\.rest$" . rst-mode)) auto-mode-alist))
diff --git a/dev-python/docutils/files/docutils-0.4-python-2.5-fix.patch b/dev-python/docutils/files/docutils-0.4-python-2.5-fix.patch
deleted file mode 100644
index 5bc0f6a7fbef..000000000000
--- a/dev-python/docutils/files/docutils-0.4-python-2.5-fix.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-Index: test/alltests.py
-===================================================================
---- test/alltests.py (revision 4628)
-+++ test/alltests.py (revision 4631)
-@@ -19,21 +19,10 @@
-
- import sys
- import os
--from types import UnicodeType
- import DocutilsTestSupport # must be imported before docutils
- import docutils
-
-
--def new_exception_str(self):
-- for i in self.args:
-- if isinstance(i, UnicodeType):
-- raise RuntimeError('Error (unicode): %r' % (self.args,))
-- return old_exception_str(self)
--
--old_exception_str = Exception.__str__
--Exception.__str__ = new_exception_str
--
--
- class Tee:
-
- """Write to a file and a stream (default: stdout) simultaneously."""
-Index: test/test_parsers/test_rst/test_directives/test_images.py
-===================================================================
---- test/test_parsers/test_rst/test_directives/test_images.py (revision 4628)
-+++ test/test_parsers/test_rst/test_directives/test_images.py (revision 4631)
-@@ -245,11 +245,11 @@
- <paragraph>
- Error in "image" directive:
- invalid option value: (option: "scale"; value: 'fifty')
-- invalid literal for int(): fifty.
-+ %s.
- <literal_block xml:space="preserve">
- .. image:: picture.png
- :scale: fifty
--"""],
-+""" % DocutilsTestSupport.exception_data('int("fifty")')[1][0]],
- ["""\
- .. image:: picture.png
- :scale: 50
-Index: test/test_parsers/test_rst/test_directives/test_contents.py
-===================================================================
---- test/test_parsers/test_rst/test_directives/test_contents.py (revision 4628)
-+++ test/test_parsers/test_rst/test_directives/test_contents.py (revision 4631)
-@@ -151,11 +151,11 @@
- <paragraph>
- Error in "contents" directive:
- invalid option value: (option: "depth"; value: 'two')
-- invalid literal for int(): two.
-+ %s.
- <literal_block xml:space="preserve">
- .. contents::
- :depth: two
--"""],
-+""" % DocutilsTestSupport.exception_data('int("two")')[1][0]],
- ["""\
- .. contents::
- :width: 2
-Index: test/test_parsers/test_rst/test_directives/test_tables.py
-===================================================================
---- test/test_parsers/test_rst/test_directives/test_tables.py (revision 4628)
-+++ test/test_parsers/test_rst/test_directives/test_tables.py (revision 4631)
-@@ -34,6 +34,16 @@
- else:
- unichr_exception_string = str(unichr_exception)
-
-+null_bytes_code = """
-+import csv
-+import cStringIO
-+csv_data = open('%s', 'rb').read().decode('latin-1')
-+csv_file = cStringIO.StringIO(csv_data)
-+reader = csv.reader(csv_file)
-+reader.next()
-+""" % utf_16_csv
-+null_bytes_exception = DocutilsTestSupport.exception_data(null_bytes_code)[1][0]
-+
- totest = {}
-
- totest['table'] = [
-@@ -549,7 +559,7 @@
- <paragraph>
- Error in "csv-table" directive:
- invalid option value: (option: "widths"; value: '10,y,z')
-- invalid literal for int(): y.
-+ %s.
- <literal_block xml:space="preserve">
- .. csv-table:: bad column widths
- :widths: 10,y,z
-@@ -565,7 +575,7 @@
- :widths: 0 0 0
- \n\
- some, csv, data
--"""],
-+""" % DocutilsTestSupport.exception_data('int("y")')[1][0]],
- ["""\
- .. csv-table:: good delimiter
- :delim: /
-@@ -734,14 +744,14 @@
- <system_message level="3" line="1" source="test data" type="ERROR">
- <paragraph>
- Error with CSV data in "csv-table" directive:
-- string with NUL bytes
-+ %s
- <literal_block xml:space="preserve">
- .. csv-table:: bad encoding
- :file: %s
- :encoding: latin-1
- <paragraph>
- (7- and 8-bit text encoded as UTF-16 has lots of null/zero bytes.)
--""" % utf_16_csv],
-+""" % (null_bytes_exception, utf_16_csv)],
- ["""\
- .. csv-table:: good encoding
- :file: %s
-Index: docutils/parsers/rst/directives/tables.py
-===================================================================
---- docutils/parsers/rst/directives/tables.py (revision 4628)
-+++ docutils/parsers/rst/directives/tables.py (revision 4631)
-@@ -259,7 +259,8 @@
-
- def parse_csv_data_into_rows(csv_data, dialect, source, options):
- # csv.py doesn't do Unicode; encode temporarily as UTF-8
-- csv_reader = csv.reader([line.encode('utf-8') for line in csv_data],
-+ csv_reader = csv.reader([(line.encode('utf-8') + '\n')
-+ for line in csv_data],
- dialect=dialect)
- rows = []
- max_cols = 0