summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-06-25 10:47:03 +0000
committerAli Polatel <hawking@gentoo.org>2008-06-25 10:47:03 +0000
commit08ca4d0523e70e1772456ccd55935cee0eecdead (patch)
treebfe908a3737fadcf4daf1f49541726af87d1b21d /dev-python/kiwi/kiwi-1.9.22.ebuild
parentVersion bump. (diff)
downloadhistorical-08ca4d0523e70e1772456ccd55935cee0eecdead.tar.gz
historical-08ca4d0523e70e1772456ccd55935cee0eecdead.tar.bz2
historical-08ca4d0523e70e1772456ccd55935cee0eecdead.zip
Version bump.
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25-gentoo-r1 x86_64
Diffstat (limited to 'dev-python/kiwi/kiwi-1.9.22.ebuild')
-rw-r--r--dev-python/kiwi/kiwi-1.9.22.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/kiwi/kiwi-1.9.22.ebuild b/dev-python/kiwi/kiwi-1.9.22.ebuild
new file mode 100644
index 000000000000..441b76f2c357
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.22.ebuild,v 1.1 2008/06/25 10:47:03 hawking Exp $
+
+NEED_PYTHON=2.3
+
+inherit distutils versionator
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/"
+SRC_URI="http://download.gnome.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/pygtk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:share/doc/kiwi:share/doc/${PF}:g" \
+ setup.py || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}