summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-01-10 21:07:05 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-01-10 21:07:05 +0000
commit06877ea79130fba73b245c92fff969076a059806 (patch)
treec1f8fb28d598e106ca90b1aefed39fce190850b9 /games-action
parentReworked the ebuild a little bit and hopefully fixed the problems people are ... (diff)
downloadhistorical-06877ea79130fba73b245c92fff969076a059806.tar.gz
historical-06877ea79130fba73b245c92fff969076a059806.tar.bz2
historical-06877ea79130fba73b245c92fff969076a059806.zip
Added modular X dependencies and marking stable on amd64.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'games-action')
-rw-r--r--games-action/mutantstorm-demo/ChangeLog8
-rw-r--r--games-action/mutantstorm-demo/Manifest6
-rw-r--r--games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild35
3 files changed, 31 insertions, 18 deletions
diff --git a/games-action/mutantstorm-demo/ChangeLog b/games-action/mutantstorm-demo/ChangeLog
index dcdc0260029b..24152f2c6b31 100644
--- a/games-action/mutantstorm-demo/ChangeLog
+++ b/games-action/mutantstorm-demo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/mutantstorm-demo
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/ChangeLog,v 1.7 2005/09/26 17:34:21 wolf31o2 Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/ChangeLog,v 1.8 2006/01/10 21:07:05 wolf31o2 Exp $
+
+ 10 Jan 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ mutantstorm-demo-1.33.ebuild:
+ Added modular X dependencies and marking stable on amd64.
26 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org>
mutantstorm-demo-1.33.ebuild:
diff --git a/games-action/mutantstorm-demo/Manifest b/games-action/mutantstorm-demo/Manifest
index dbab28ed1d1f..5f31703b9759 100644
--- a/games-action/mutantstorm-demo/Manifest
+++ b/games-action/mutantstorm-demo/Manifest
@@ -1,4 +1,4 @@
-MD5 85697c4c262bd933a0792bf02352fa5e mutantstorm-demo-1.33.ebuild 1115
-MD5 1615aa99cfc227736ad47d9d80e92650 ChangeLog 1197
-MD5 6b51671b3cff5b6edcd13d8bd753e726 metadata.xml 1758
+MD5 2b1f0b0a26ab9c3e3a50cadb2c000ce1 ChangeLog 1344
MD5 93b8ddcfff567acf04a76cbfb5ee8d42 files/digest-mutantstorm-demo-1.33 73
+MD5 6b51671b3cff5b6edcd13d8bd753e726 metadata.xml 1758
+MD5 2475a24f7ce2bfe0f6fba49afcfff871 mutantstorm-demo-1.33.ebuild 1340
diff --git a/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
index c48205258f04..7ce5431d3142 100644
--- a/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
+++ b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild,v 1.5 2005/09/26 17:34:21 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild,v 1.6 2006/01/10 21:07:05 wolf31o2 Exp $
inherit eutils games
@@ -10,17 +10,25 @@ SRC_URI="ftp://ggdev-1.homelan.com/mutantstorm/MutantStormDemo_${PV/./_}.sh.bin"
LICENSE="POMPOM"
SLOT="0"
-KEYWORDS="-* x86 ~amd64"
+KEYWORDS="-* amd64 x86"
IUSE=""
-S=${WORKDIR}
-
RDEPEND="virtual/opengl
amd64? (
app-emulation/emul-linux-x86-xlibs
app-emulation/emul-linux-x86-soundlibs
app-emulation/emul-linux-x86-compat
- app-emulation/emul-linux-x86-sdl )"
+ app-emulation/emul-linux-x86-sdl )
+ x86? (
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXext )
+ virtual/x11 ) )"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
pkg_setup() {
check_license POMPOM
@@ -32,16 +40,17 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
- dodir ${dir} ${GAMES_BINDIR}
-
- cp -r menu script styles ${D}/${dir}/
+ insinto "${dir}"
+ doins -r menu script styles "${dir}"
- exeinto ${dir}
+ exeinto "${dir}"
doexe bin/Linux/x86/*
- dosym ${dir}/mutantstormdemo ${GAMES_BINDIR}/mutantstorm-demo
+ # Remove libSDL since we use the system version and our version doesn't
+ # have TEXTRELs in it.
+ rm -f "${Ddir}"/libSDL-1.2.so.0.0.5
+ games_make_wrapper mutantstorm-demo ./mutantstormdemo "${dir}" "${dir}"
- insinto ${dir}
+ insinto "${dir}"
doins README.txt buy_me mutant.xpm pompom readme.htm
prepgamesdirs