summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-03 02:47:55 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-03 02:47:55 +0000
commit1421dbfa4c86bbb67147d7809c0a2ffc8627883f (patch)
tree005e385f6472d29ead930d46b5eb80d6f4147e1d /games-fps/alephone
parentMarked as stable on amd64 and sparc. (diff)
downloadhistorical-1421dbfa4c86bbb67147d7809c0a2ffc8627883f.tar.gz
historical-1421dbfa4c86bbb67147d7809c0a2ffc8627883f.tar.bz2
historical-1421dbfa4c86bbb67147d7809c0a2ffc8627883f.zip
initial ebuild #43303
Diffstat (limited to 'games-fps/alephone')
-rw-r--r--games-fps/alephone/ChangeLog8
-rw-r--r--games-fps/alephone/Manifest15
-rw-r--r--games-fps/alephone/alephone-20040417.ebuild46
-rw-r--r--games-fps/alephone/files/20040417-gcc34.patch24
-rw-r--r--games-fps/alephone/files/digest-alephone-200404171
-rw-r--r--games-fps/alephone/metadata.xml5
6 files changed, 99 insertions, 0 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
new file mode 100644
index 000000000000..72de3f2d29e3
--- /dev/null
+++ b/games-fps/alephone/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-fps/alephone
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.1 2005/01/03 02:47:55 vapier Exp $
+
+*alephone-20040417 (02 Jan 2004)
+
+ 02 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Will McQueen / James Le Cuirot #43303.
diff --git a/games-fps/alephone/Manifest b/games-fps/alephone/Manifest
new file mode 100644
index 000000000000..43d77291b1a4
--- /dev/null
+++ b/games-fps/alephone/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e9741acebc0caec5efaa092f3641993c ChangeLog 373
+MD5 e609b79879668d1ba862a11bcb26daf4 alephone-20040417.ebuild 1166
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 d066c158a9be84eb6b74e20a66370581 files/digest-alephone-20040417 68
+MD5 7c6943e706d040641031e7d8325b4e74 files/20040417-gcc34.patch 1567
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFB2LJrroRuSHgZdywRAnmwAJ9RSOnnhvmQu3WKlqizX3R8TxW/MQCeNVv0
+36jLKtqle20013YBTbmqHLc=
+=vdcg
+-----END PGP SIGNATURE-----
diff --git a/games-fps/alephone/alephone-20040417.ebuild b/games-fps/alephone/alephone-20040417.ebuild
new file mode 100644
index 000000000000..948607b79382
--- /dev/null
+++ b/games-fps/alephone/alephone-20040417.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20040417.ebuild,v 1.1 2005/01/03 02:47:55 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="An enhanced version of the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/aleph-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="opengl lua"
+
+DEPEND="opengl? ( virtual/opengl )
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-net
+ lua? ( dev-lang/lua )"
+
+S=${WORKDIR}/aleph_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${PV}-gcc34.patch
+ NO_CONFIGURE=bah ./autogen.sh || die "autogen failed"
+}
+
+src_compile() {
+ egamesconf $(use_enable opengl) || die
+ if ! use lua ; then
+ # stupid configure script doesnt have an option
+ sed -i '/HAVE_LUA/d' config.h || die "sed HAVE_LUA"
+ sed -i '/^LIBS/s:-llua -llualib::' $(find -name Makefile) || die "sed -llua"
+ fi
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS README docs/Cheat_Codes
+ dohtml docs/MML.html
+ prepgamesdirs
+}
diff --git a/games-fps/alephone/files/20040417-gcc34.patch b/games-fps/alephone/files/20040417-gcc34.patch
new file mode 100644
index 000000000000..a6a96fac5748
--- /dev/null
+++ b/games-fps/alephone/files/20040417-gcc34.patch
@@ -0,0 +1,24 @@
+diff -Naur aleph_20040417.orig/Source_Files/GameWorld/TickBasedCircularQueue.h aleph_20040417.new/Source_Files/GameWorld/TickBasedCircularQueue.h
+--- aleph_20040417.orig/Source_Files/GameWorld/TickBasedCircularQueue.h 2005-01-02 18:33:55.919198281 +0000
++++ aleph_20040417.new/Source_Files/GameWorld/TickBasedCircularQueue.h 2005-01-02 18:36:07.587086057 +0000
+@@ -166,7 +166,7 @@
+ class MutableElementsTickBasedCircularQueue : public ConcreteTickBasedCircularQueue<tValueType> {
+ public:
+ MutableElementsTickBasedCircularQueue(int inBufferCapacity) : ConcreteTickBasedCircularQueue<tValueType>(inBufferCapacity) {}
+- tValueType& at(int32 inTick) { return elementForTick(inTick); }
++ tValueType& at(int32 inTick) { return this->elementForTick(inTick); }
+ tValueType& operator [](int32 inTick) { return at(inTick); }
+ };
+
+diff -Naur aleph_20040417.orig/Source_Files/ModelView/Dim3_Loader.cpp aleph_20040417.new/Source_Files/ModelView/Dim3_Loader.cpp
+--- aleph_20040417.orig/Source_Files/ModelView/Dim3_Loader.cpp 2005-01-02 18:33:55.886203321 +0000
++++ aleph_20040417.new/Source_Files/ModelView/Dim3_Loader.cpp 2005-01-02 18:34:29.291100734 +0000
+@@ -225,7 +225,7 @@
+ {
+ size_t NumBones = Model.Bones.size();
+ BoneIndices.resize(NumBones);
+- fill(BoneIndices.begin(),BoneIndices.end(),UNONE); // No bones listed -- yet
++ fill(BoneIndices.begin(),BoneIndices.end(),(size_t) UNONE); // No bones listed -- yet
+ vector<Model3D_Bone> SortedBones(NumBones);
+ vector<size_t> BoneStack(NumBones);
+ vector<bool> BonesUsed(NumBones);
diff --git a/games-fps/alephone/files/digest-alephone-20040417 b/games-fps/alephone/files/digest-alephone-20040417
new file mode 100644
index 000000000000..10582c22ea9c
--- /dev/null
+++ b/games-fps/alephone/files/digest-alephone-20040417
@@ -0,0 +1 @@
+MD5 331d36c73672984df6ab5cd373552b22 aleph-20040417.tar.bz2 2293780
diff --git a/games-fps/alephone/metadata.xml b/games-fps/alephone/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/alephone/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>