summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-08-26 22:14:40 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-08-26 22:14:40 +0000
commit4f9bc523d5cb0bb918647af4ec2ca8b47ad8f149 (patch)
tree8cefc1d5dee9f6ff8fa0e9394a8ec5a6ae78f0ea /media-sound
parentmasked the new and reworked audacity (diff)
downloadhistorical-4f9bc523d5cb0bb918647af4ec2ca8b47ad8f149.tar.gz
historical-4f9bc523d5cb0bb918647af4ec2ca8b47ad8f149.tar.bz2
historical-4f9bc523d5cb0bb918647af4ec2ca8b47ad8f149.zip
new and reworked audacity + id3lib
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacity/ChangeLog8
-rw-r--r--media-sound/audacity/audacity-1.0.0-r2.ebuild75
-rw-r--r--media-sound/audacity/files/digest-audacity-1.0.0-r22
-rw-r--r--media-sound/audacity/files/id3lib-3.8.0-gcc3.patch97
4 files changed, 181 insertions, 1 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 79119a74ad05..09a353afa909 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacity
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.3 2002/08/22 23:54:12 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.4 2002/08/26 22:14:40 spider Exp $
+
+*audacity-1.0.0-r2 (26 Aug 2002)
+ 26 Aug 2002; Spider <spider@gentoo.org> audacity-1.0.0-r2.ebuild :
+ removed id3lib_pre2 in the ebuild in favour of the final + patches for it to work with gcc 3.2. now it should emerge clean on gcc 3.2 systems.
+
+ masked for testing on gcc 2.95.3
*audacity-1.0.0-r1 (09 Aug 2002)
diff --git a/media-sound/audacity/audacity-1.0.0-r2.ebuild b/media-sound/audacity/audacity-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..fa9033964d88
--- /dev/null
+++ b/media-sound/audacity/audacity-1.0.0-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.0.0-r2.ebuild,v 1.1 2002/08/26 22:14:40 spider Exp $
+
+
+MY_P="${PN}-src-${PV}"
+ID3V="id3lib-3.8.0"
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A free, crossplatform audio editor."
+SRC_URI="mirror://sourceforge/audacity/${MY_P}.tgz
+ mirror://sourceforge/id3lib/${ID3V}.tar.gz"
+
+#the included id3lib breaks and I figure its better to
+# update to stable than to attempt to hack the patch
+# spider //
+
+HOMEPAGE="http://audacity.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+# doesn't compile with wxGTK-2.3.2
+DEPEND="~x11-libs/wxGTK-2.2.9
+ oggvorbis? ( media-libs/libvorbis )
+ app-arch/zip"
+RDEPEND=${DEPEND}
+
+
+src_unpack() {
+ unpack ${MY_P}.tgz
+
+
+## id3lib hack
+ cd ${WORKDIR}/audacity-src-${PV}
+ unpack ${ID3V}.tar.gz
+ rm -rf id3lib
+ mv ${ID3V} id3lib
+
+
+
+ # Only patch if using gcc 3.x
+ if [ "`eval echo \`gcc -dumpversion\` | cut -f1 -d.`" -eq 3 ]
+ then
+ cd ${WORKDIR}/audacity-src-${PV}/id3lib
+ # updated patch from id3lib
+ pwd
+ patch -p0 <${FILESDIR}/${ID3V}-gcc3.patch ||die "foo "
+
+ # patch -p1 <${FILESDIR}/${P}-gcc31.patch || die
+ fi
+}
+
+src_compile() {
+ local myconf
+ myconf="--with-id3"
+ use oggvorbis && myconf="${myconf} --with-vorbis"
+
+ # arts is broken! :(
+ # use arts && myconf="${myconf} --with-arts-soundserver"
+
+ cd ${WORKDIR}/audacity-src-1.0.0
+ ./configure --prefix=/usr $myconf || die
+
+ make || die
+}
+
+src_install () {
+ cd ${WORKDIR}/audacity-src-1.0.0
+
+ export PREFIX=${D}/usr
+ make -e install || die
+}
+
diff --git a/media-sound/audacity/files/digest-audacity-1.0.0-r2 b/media-sound/audacity/files/digest-audacity-1.0.0-r2
new file mode 100644
index 000000000000..af486024aa98
--- /dev/null
+++ b/media-sound/audacity/files/digest-audacity-1.0.0-r2
@@ -0,0 +1,2 @@
+MD5 6711813f16c3d64e63209cb355191af6 audacity-src-1.0.0.tgz 1699883
+MD5 9d5947e2c25c846b03faadfb8c6e8601 id3lib-3.8.0.tar.gz 934333
diff --git a/media-sound/audacity/files/id3lib-3.8.0-gcc3.patch b/media-sound/audacity/files/id3lib-3.8.0-gcc3.patch
new file mode 100644
index 000000000000..12c8bc5ab37a
--- /dev/null
+++ b/media-sound/audacity/files/id3lib-3.8.0-gcc3.patch
@@ -0,0 +1,97 @@
+--- include/id3/id3lib_strings.h.orig 2002-08-21 16:41:11.000000000 -0600
++++ include/id3/id3lib_strings.h 2002-08-21 16:40:32.000000000 -0600
+@@ -30,6 +30,94 @@
+
+ #include <string>
+
++#if (defined(__GNUC__) && (__GNUC__ >= 3) || (defined(_MSC_VER) && _MSC_VER > 1000))
++namespace std
++{
++ template<>
++ struct char_traits<unsigned char>
++ {
++ typedef unsigned char char_type;
++ // Unsigned as wint_t in unsigned.
++ typedef unsigned long int_type;
++ typedef streampos pos_type;
++ typedef streamoff off_type;
++ typedef mbstate_t state_type;
++
++ static void
++ assign(char_type& __c1, const char_type& __c2)
++ { __c1 = __c2; }
++
++ static bool
++ eq(const char_type& __c1, const char_type& __c2)
++ { return __c1 == __c2; }
++
++ static bool
++ lt(const char_type& __c1, const char_type& __c2)
++ { return __c1 < __c2; }
++
++ static int
++ compare(const char_type* __s1, const char_type* __s2, size_t __n)
++ {
++ for (size_t __i = 0; __i < __n; ++__i)
++ if (!eq(__s1[__i], __s2[__i]))
++ return lt(__s1[__i], __s2[__i]) ? -1 : 1;
++ return 0;
++ }
++
++ static size_t
++ length(const char_type* __s)
++ {
++ const char_type* __p = __s;
++ while (__p)
++ ++__p;
++ return (__p - __s);
++ }
++
++ static const char_type*
++ find(const char_type* __s, size_t __n, const char_type& __a)
++ {
++ for (const char_type* __p = __s; size_t(__p - __s) < __n; ++__p)
++ if (*__p == __a) return __p;
++ return 0;
++ }
++
++ static char_type*
++ move(char_type* __s1, const char_type* __s2, size_t __n)
++ { return (char_type*) memmove(__s1, __s2, __n * sizeof(char_type)); }
++
++ static char_type*
++ copy(char_type* __s1, const char_type* __s2, size_t __n)
++ { return (char_type*) memcpy(__s1, __s2, __n * sizeof(char_type)); }
++
++ static char_type*
++ assign(char_type* __s, size_t __n, char_type __a)
++ {
++ for (char_type* __p = __s; __p < __s + __n; ++__p)
++ assign(*__p, __a);
++ return __s;
++ }
++
++ static char_type
++ to_char_type(const int_type& __c)
++ { return char_type(); }
++
++ static int_type
++ to_int_type(const char_type& __c) { return int_type(); }
++
++ static bool
++ eq_int_type(const int_type& __c1, const int_type& __c2)
++ { return __c1 == __c2; }
++
++ static int_type
++ eof() { return static_cast<int_type>(-1); }
++
++ static int_type
++ not_eof(const int_type& __c)
++ { return eq_int_type(__c, eof()) ? int_type(0) : __c; }
++ };
++} // namespace std
++#endif
++
+ namespace dami
+ {
+ typedef std::basic_string<char> String;