summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-28 06:58:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-28 06:58:40 +0000
commit933216a69b0e45cc1feae7ad9d3d3c8ce1790f5f (patch)
tree661621fb0af5d2fae8721fbcf5d2fd5fdfda844c /media-sound
parentstable on ppc (Bug #148798) (diff)
downloadhistorical-933216a69b0e45cc1feae7ad9d3d3c8ce1790f5f.tar.gz
historical-933216a69b0e45cc1feae7ad9d3d3c8ce1790f5f.tar.bz2
historical-933216a69b0e45cc1feae7ad9d3d3c8ce1790f5f.zip
Version bump.
Package-Manager: portage-2.1.2_pre1-r3
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.13_rc3.ebuild179
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.13_rc33
-rw-r--r--media-sound/alsa-headers/ChangeLog8
-rw-r--r--media-sound/alsa-headers/alsa-headers-1.0.13_rc3.ebuild44
-rw-r--r--media-sound/alsa-headers/files/digest-alsa-headers-1.0.13_rc33
-rw-r--r--media-sound/alsa-utils/ChangeLog8
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.13_rc3.ebuild84
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-1.0.13_rc33
9 files changed, 337 insertions, 3 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 2fcd3deefe4a..4db611925d8d 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.224 2006/09/16 12:14:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.225 2006/09/28 06:58:39 flameeyes Exp $
+
+*alsa-driver-1.0.13_rc3 (28 Sep 2006)
+
+ 28 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-driver-1.0.13_rc3.ebuild:
+ Version bump.
*alsa-driver-1.0.13_rc2 (16 Sep 2006)
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.13_rc3.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.13_rc3.ebuild
new file mode 100644
index 000000000000..5b12e0baec23
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-1.0.13_rc3.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.13_rc3.ebuild,v 1.1 2006/09/28 06:58:39 flameeyes Exp $
+
+inherit linux-mod flag-o-matic eutils multilib
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="oss doc debug"
+
+RDEPEND="virtual/modutils
+ ~media-sound/alsa-headers-${PV}
+ !media-sound/snd-aoa"
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ sparc? ( >=sys-devel/autoconf-2.50 )
+ sys-apps/debianutils"
+
+PROVIDE="virtual/alsa"
+
+pkg_setup() {
+ # By default, drivers for all supported cards will be compiled.
+ # If you want to only compile for specific card(s), set ALSA_CARDS
+ # environment to a space-separated list of drivers that you want to build.
+ # For example:
+ #
+ # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+ #
+ ALSA_CARDS=${ALSA_CARDS:-all}
+
+ # Which drivers need PNP
+ local PNP_DRIVERS="interwave interwave-stb"
+
+ CONFIG_CHECK="SOUND"
+ SND_ERROR="ALSA is already compiled into the kernel."
+ SOUND_ERROR="Your kernel doesn't have sound support enabled."
+ SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
+ PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+ if [[ "${ALSA_CARDS}" == "all" ]]; then
+
+ # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
+ if [[ ${ARCH} != "ppc" ]]; then
+ CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ fi
+ else
+ for pnpdriver in ${PNP_DRIVERS}; do
+ hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ done
+ fi
+
+ linux-mod_pkg_setup
+
+ if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
+ export CBUILD=${CBUILD-${CHOST}}
+ export CHOST="sparc64-unknown-linux-gnu"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.10_rc1-include.patch"
+
+ epatch "${FILESDIR}/${PN}-mcp55.patch"
+
+ if kernel_is ge 2 6 17 ; then
+ # These are needed for some drivers to build with kernel 2.6.17
+ # until a refreshed release of alsa-driver is done
+ epatch "${FILESDIR}/${PN}-1.0.11-kernel-2.6.17.patch"
+
+ # asihpi driver is broken, skip it until upstream releases something
+ # working.
+ sed -i -e 's:asihpi/::' "${S}/pci/Makefile"
+ fi
+
+ convert_to_m "${S}/Makefile"
+ sed -i -e 's:\(.*depmod\):#\1:' "${S}/Makefile"
+}
+
+src_compile() {
+ local myABI=${ABI:-${DEFAULT_ABI}}
+
+ # Should fix bug #46901
+ is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
+ append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
+
+ econf $(use_with oss) \
+ $(use_with debug debug full) \
+ --with-kernel="${KV_DIR}" \
+ --with-build="${KV_OUT_DIR}" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-cards="${ALSA_CARDS}" || die "econf failed"
+
+ # linux-mod_src_compile doesn't work well with alsa
+
+ ARCH=$(tc-arch-kernel)
+ ABI=${KERNEL_ABI}
+ emake LDFLAGS="$(raw-ldflags)" HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
+ ARCH=$(tc-arch)
+ ABI=${myABI}
+
+ if use doc;
+ then
+ ebegin "Building Documentation"
+ cd ${S}/scripts
+ emake || die Failed making docs in ${S}/scripts
+
+ cd ${S}/doc/DocBook
+ emake || die Failed making docs in ${S}/doc/DocBook
+ eend $?
+ fi
+}
+
+
+src_install() {
+ emake DESTDIR=${D} install-modules || die "make install failed"
+
+ dodoc CARDS-STATUS FAQ README WARNING TODO
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
+
+ docinto DocBook
+ dodoc doc/DocBook/*
+ rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
+
+ docinto Documentation
+ dodoc sound/Documentation/*
+ fi
+
+ if kernel_is 2 6; then
+ # mv the drivers somewhere they won't be killed by the kernel's make modules_install
+ mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
+ rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use the 'alsamixer' program to unmute them."
+ einfo
+ einfo "Version 1.0.3 and above should work with version 2.6 kernels."
+ einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
+ einfo
+
+ linux-mod_pkg_postinst
+
+ einfo "Check out the ALSA installation guide availible at the following URL:"
+ einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
+
+ if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
+ # Cleanup if they had older alsa installed
+ for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
+ rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
+ done
+
+ for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
+ rmdir ${dir} &> /dev/null
+ done
+ fi
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.13_rc3 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.13_rc3
new file mode 100644
index 000000000000..c691acf8ca4c
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.13_rc3
@@ -0,0 +1,3 @@
+MD5 2377640dc2256452f2ce07d3f60fec22 alsa-driver-1.0.13rc3.tar.bz2 2404882
+RMD160 4ede76978803ca59445d2fa00bc59ba6ae30242e alsa-driver-1.0.13rc3.tar.bz2 2404882
+SHA256 2ca1ac725d75cf24ff540d5e7bd2057083af32c476b397c5f4a4282f96bbaf48 alsa-driver-1.0.13rc3.tar.bz2 2404882
diff --git a/media-sound/alsa-headers/ChangeLog b/media-sound/alsa-headers/ChangeLog
index ade170a83579..b6afbd5196ad 100644
--- a/media-sound/alsa-headers/ChangeLog
+++ b/media-sound/alsa-headers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-headers
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.85 2006/09/16 12:14:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.86 2006/09/28 06:56:55 flameeyes Exp $
+
+*alsa-headers-1.0.13_rc3 (28 Sep 2006)
+
+ 28 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-headers-1.0.13_rc3.ebuild:
+ Version bump.
*alsa-headers-1.0.13_rc2 (16 Sep 2006)
diff --git a/media-sound/alsa-headers/alsa-headers-1.0.13_rc3.ebuild b/media-sound/alsa-headers/alsa-headers-1.0.13_rc3.ebuild
new file mode 100644
index 000000000000..28d2071c3527
--- /dev/null
+++ b/media-sound/alsa-headers/alsa-headers-1.0.13_rc3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-1.0.13_rc3.ebuild,v 1.1 2006/09/28 06:56:55 flameeyes Exp $
+
+inherit eutils
+
+MY_PN=${PN/headers/driver}
+MY_P="${MY_PN}-${PV/_rc/rc}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+# Remove the sound symlink workaround...
+pkg_setup() {
+ if [[ -L "${ROOT}/usr/include/sound" ]]; then
+ rm "${ROOT}/usr/include/sound"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.0.6a-user.patch"
+}
+
+src_compile() {
+ einfo "No compilation neccessary"
+}
+
+src_install() {
+ cd "${S}/alsa-kernel/include"
+ insinto /usr/include/sound
+ doins *.h || die "include failed"
+}
diff --git a/media-sound/alsa-headers/files/digest-alsa-headers-1.0.13_rc3 b/media-sound/alsa-headers/files/digest-alsa-headers-1.0.13_rc3
new file mode 100644
index 000000000000..c691acf8ca4c
--- /dev/null
+++ b/media-sound/alsa-headers/files/digest-alsa-headers-1.0.13_rc3
@@ -0,0 +1,3 @@
+MD5 2377640dc2256452f2ce07d3f60fec22 alsa-driver-1.0.13rc3.tar.bz2 2404882
+RMD160 4ede76978803ca59445d2fa00bc59ba6ae30242e alsa-driver-1.0.13rc3.tar.bz2 2404882
+SHA256 2ca1ac725d75cf24ff540d5e7bd2057083af32c476b397c5f4a4282f96bbaf48 alsa-driver-1.0.13rc3.tar.bz2 2404882
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index db9880183193..63b3dca97123 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.158 2006/09/23 13:38:53 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.159 2006/09/28 06:57:12 flameeyes Exp $
+
+*alsa-utils-1.0.13_rc3 (28 Sep 2006)
+
+ 28 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-utils-1.0.13_rc3.ebuild:
+ Version bump.
23 Sep 2006; Stefan Schweizer <genstef@gentoo.org>
files/alsa-modules.conf-rc:
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.13_rc3.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.13_rc3.ebuild
new file mode 100644
index 000000000000..f818fcde329c
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.13_rc3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.13_rc3.ebuild,v 1.1 2006/09/28 06:57:12 flameeyes Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-1.0.12"
+RDEPEND="${DEPEND}
+ sys-apps/pciutils"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+ epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ newconfd "${FILESDIR}/alsasound.confd" alsasound
+ insinto /etc/modules.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+ newinitd "${FILESDIR}/alsasound-1.0.10_rc2" alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run modules-update. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && modules-update"
+ echo
+
+ if use sparc; then
+ ewarn "Old versions of alsa-drivers had a broken snd-ioctl32 module"
+ ewarn "which causes sparc64 machines to lockup on such tasks as"
+ ewarn "changing the volume. Because of this, it is VERY important"
+ ewarn "that you do not use the snd-ioctl32 modules contained in"
+ ewarn "development-sources or <=gentoo-dev-sources-2.6.7-r14. Doing so"
+ ewarn "may result in an unbootable system if you start alsasound at boot."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13_rc3 b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13_rc3
new file mode 100644
index 000000000000..32f99d10fd77
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13_rc3
@@ -0,0 +1,3 @@
+MD5 5ce9213b24f139e73c220f8a952368df alsa-utils-1.0.13rc3.tar.bz2 981004
+RMD160 cb4fb913bec54c57fb5dfd53f4534fe9e7357f4c alsa-utils-1.0.13rc3.tar.bz2 981004
+SHA256 8bfd924dcd1eaff4cfc84f0c272e8a06a03c9d73b86629d6d6861d336876752a alsa-utils-1.0.13rc3.tar.bz2 981004