summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-26 19:55:10 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-26 19:55:10 +0000
commit21486cf36292f2d04796f8a411fc194efa85f844 (patch)
tree9b003841b631648ac4ebf700c0180bad8e594c2a /net-analyzer
parentUpdated ChangeLog to reflect net-analyzer/nessus-libraries instead of net-mis... (diff)
downloadhistorical-21486cf36292f2d04796f8a411fc194efa85f844.tar.gz
historical-21486cf36292f2d04796f8a411fc194efa85f844.tar.bz2
historical-21486cf36292f2d04796f8a411fc194efa85f844.zip
Split out the "nessus" ebuild to the individual nessues components to allow pieces to build and install properly. "nessus" is still an installable ebuild, it just pulls in the individual components. libnasl is the second of those components.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/libnasl/ChangeLog13
-rw-r--r--net-analyzer/libnasl/files/digest-libnasl-1.2.31
-rw-r--r--net-analyzer/libnasl/files/nasl.diff11
-rw-r--r--net-analyzer/libnasl/libnasl-1.2.3.ebuild46
4 files changed, 71 insertions, 0 deletions
diff --git a/net-analyzer/libnasl/ChangeLog b/net-analyzer/libnasl/ChangeLog
new file mode 100644
index 000000000000..fb74a184dd29
--- /dev/null
+++ b/net-analyzer/libnasl/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-analyzer/libnasl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/ChangeLog,v 1.1 2002/07/26 19:55:10 raker Exp $
+
+*libnasl-1.2.3 (26 Jul 2002)
+
+ 26 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ libnasl-1.2.3.ebuild, files/digest-libnasl-1.2.3, files/nasl.diff :
+
+ Split out the "nessus" ebuild to the individual nessues components
+ to allow pieces to build and install properly. "nessus" is still
+ an installable ebuild, it just pulls in the individual components.
+ libnasl is the second of those components.
diff --git a/net-analyzer/libnasl/files/digest-libnasl-1.2.3 b/net-analyzer/libnasl/files/digest-libnasl-1.2.3
new file mode 100644
index 000000000000..e87a7133700e
--- /dev/null
+++ b/net-analyzer/libnasl/files/digest-libnasl-1.2.3
@@ -0,0 +1 @@
+MD5 ae16346e215ff752a28de252bfeb6800 libnasl-1.2.3.tar.gz 293239
diff --git a/net-analyzer/libnasl/files/nasl.diff b/net-analyzer/libnasl/files/nasl.diff
new file mode 100644
index 000000000000..a1b0120da105
--- /dev/null
+++ b/net-analyzer/libnasl/files/nasl.diff
@@ -0,0 +1,11 @@
+diff -urN libnasl/nasl/Makefile libnasl-modified/nasl/Makefile
+--- libnasl/nasl/Makefile Mon Oct 15 12:58:07 2001
++++ libnasl-modified/nasl/Makefile Fri Jul 26 12:56:36 2002
+@@ -41,6 +41,7 @@
+
+ install : libnasl.la nasl
+ test -d ${libdir} || $(INSTALL_DIR) -m 755 ${libdir}
++ test -d ${bindir} || $(INSTALL_DIR) -m 755 ${bindir}
+ $(LIBTOOL) --mode install $(INSTALL) libnasl.la ${libdir}/libnasl.la
+ $(LIBTOOL) --finish ${libdir}
+ $(INSTALL) nasl ${bindir}/
diff --git a/net-analyzer/libnasl/libnasl-1.2.3.ebuild b/net-analyzer/libnasl/libnasl-1.2.3.ebuild
new file mode 100644
index 000000000000..1f67d19f4d86
--- /dev/null
+++ b/net-analyzer/libnasl/libnasl-1.2.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2000-2002 Achim Gottinger
+# Distributed under the GPL by Gentoo Technologies, Inc.
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-1.2.3.ebuild,v 1.1 2002/07/26 19:55:10 raker Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A remote security scanner for Linux (libnasl)"
+HOMEPAGE="http://www.nessus.org/"
+
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-1.2.3/src/${P}.tar.gz"
+
+DEPEND="=net-analyzer/nessus-libraries-1.2.3"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc -sparc -sparc64"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/nasl.diff
+
+}
+
+src_compile() {
+
+ econf || die "configuration failed"
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/state \
+ mandir=${D}/usr/share/man \
+ install || die "Install failed libnasl"
+
+ cd ${S}
+ docinto libnasl
+ dodoc COPYING TODO
+
+}