summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2011-10-09 17:29:41 +0000
committerHanno Boeck <hanno@gentoo.org>2011-10-09 17:29:41 +0000
commit42479fa745303bf48c144c9461441ad9afd2db3b (patch)
tree538ae4f5ce615a9fd39b37c20ef63c37d35cf82f /net-analyzer
parentppc stable wrt #380525 (diff)
downloadhistorical-42479fa745303bf48c144c9461441ad9afd2db3b.tar.gz
historical-42479fa745303bf48c144c9461441ad9afd2db3b.tar.bz2
historical-42479fa745303bf48c144c9461441ad9afd2db3b.zip
Initial commit of greenbone-security-assistant, part of openvas 4.
Package-Manager: portage-2.1.10.24/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/greenbone-security-assistant/ChangeLog10
-rwxr-xr-xnet-analyzer/greenbone-security-assistant/files/gsad23
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild36
-rw-r--r--net-analyzer/greenbone-security-assistant/metadata.xml5
-rw-r--r--net-analyzer/greenbone-security-desktop/Manifest24
5 files changed, 98 insertions, 0 deletions
diff --git a/net-analyzer/greenbone-security-assistant/ChangeLog b/net-analyzer/greenbone-security-assistant/ChangeLog
new file mode 100644
index 000000000000..57b78abb9793
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/greenbone-security-assistant
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/ChangeLog,v 1.1 2011/10/09 17:29:41 hanno Exp $
+
+*greenbone-security-assistant-2.0.1 (09 Oct 2011)
+
+ 09 Oct 2011; Hanno Boeck <hanno@gentoo.org>
+ +greenbone-security-assistant-2.0.1.ebuild, +files/gsad, +metadata.xml:
+ Initial commit of Greenbone Security Assistant, part of openvas.
+
diff --git a/net-analyzer/greenbone-security-assistant/files/gsad b/net-analyzer/greenbone-security-assistant/files/gsad
new file mode 100755
index 000000000000..58c0030b22d1
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/files/gsad
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Greenbone Security Assistant Daemon"
+ start-stop-daemon --start --name gsad \
+ --exec /usr/sbin/gsad \
+ --pidfile /var/run/gsad.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stop openvassd"
+ start-stop-daemon --stop --name gsad \
+ --pidfile /var/run/gsad.pid
+ eend $?
+}
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
new file mode 100644
index 000000000000..65d2fd748de6
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-2.0.1.ebuild,v 1.1 2011/10/09 17:29:41 hanno Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Greenbone Security Assistant for openvas"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/857/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-analyzer/openvas-libraries-4
+ dev-libs/libxslt
+ net-libs/libmicrohttpd"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/cmake"
+
+# Workaround for upstream bug, it doesn't like out-of-tree builds.
+CMAKE_BUILD_DIR="${S}"
+
+src_configure() {
+ local mycmakeargs="-DLOCALSTATEDIR=/var -DSYSCONFDIR=/etc"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc ChangeLog CHANGES README || die "dodoc failed"
+ doinitd "${FILESDIR}"/gsad || die
+}
diff --git a/net-analyzer/greenbone-security-assistant/metadata.xml b/net-analyzer/greenbone-security-assistant/metadata.xml
new file mode 100644
index 000000000000..8cb548491f4e
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/greenbone-security-desktop/Manifest b/net-analyzer/greenbone-security-desktop/Manifest
new file mode 100644
index 000000000000..44b7e61ab8dc
--- /dev/null
+++ b/net-analyzer/greenbone-security-desktop/Manifest
@@ -0,0 +1,24 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST greenbone-security-desktop-1.2.0.tar.gz 663457 RMD160 267ff506ac37abed00a041f67983646cb18bfa97 SHA1 3a1562a311e895e3676c059d0ee93a5ee05576b4 SHA256 8d85c6a8e805bbf9a599c3fe94b16261f44156e15923b1ca6ee734789944813a
+EBUILD greenbone-security-desktop-1.2.0.ebuild 986 RMD160 c3e840a5065ec2d1b90871b773daccb2546eb530 SHA1 148b3bc98866025b9c21db86eff0d13f5fda829a SHA256 9be787b4e1dce801cc6389ae60f037471d885f0c04258d0c58f52c06a74acbba
+MISC ChangeLog 440 RMD160 26d3cf2ce1385c1fd36300171f39ae231c559ead SHA1 7992bb23b0252c43e6b946028fabda66af4018b1 SHA256 8d78b6dfc95b0a088d7df7b6db6b8ab559ffe1da145fe1c86b8f25c0c4462359
+MISC metadata.xml 196 RMD160 38d93373061ffec39f901f9710573fe2eb6224fc SHA1 9f792f2f8c83cd88b49c8d7e989604a2b21cff6e SHA256 e8ef5daeda229c876fcf81068b64452d16ca1674618ee72fe8c294f6ead29445
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iQIcBAEBCAAGBQJOkfcQAAoJEKWIAHK7tR5C80cQAJjTDKlk2znopoz14RoVFDi2
+GduDuS21n9GsjbnjVHENzFdaLUZAkp/esdPVy9OXelwWK/8tuQ4p8ICzQQUrkgOE
+kOfH8OO9cKgRpduelF+vXXyvQYbbufKX2h+Hwtd+atw67l1fdh01F7e6k0vDDtP7
+SBsuLV7wKgLaWXrS3Ql/HhO7LMnub/BIH7xAiox2KpA2cu1Y8YIb9qxkfWB7YllL
+KhqpdOIUj6Igq6cZWk0ebLvi8nZA0Z9opAlJifX1L0cr3bcMzVw4ppCQWoIl/Uvy
+A4M198uAJ8Ye3FtjMcCfJpF5B52nX531BG8bWO1Zoowftt4S75Xi2rKDGAdZIeRp
+XEF7S9gtVTHhLIOPBLHURAvkua5PBA9JyJe9cSwpX0ko80B/hiOwspQWfHehKIet
+A+Y5G8PFScUqMxlWQS8AnNG78RkpPkSdHL7VgMU3YHJJImbmHL5FpmyKzOY9kVor
+2bSWutHhO0j2HkK4HOXhG00HuxIpdPV71HdjP2lukgUOxAZKYVheZGp7gxzZB5/h
+89hvm5UeAdFFdM050kdre9tsJRf4r3EFzZXKCXOaE8NVe3XYfZrtzkFWVV1Dcymt
+xCJjPGPgX3NvHqtyiW87m/Y6MdQghQ4mXWvwAvTppfkM6ESGeU+1kKcD0vPmUw9u
+WxStpakFOATa016czqMz
+=e6Ao
+-----END PGP SIGNATURE-----