summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-08 23:11:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-08 23:11:33 +0000
commit959bd9b84d4c212aede67a02f8ba8b62b6e34c63 (patch)
tree9ed5791b635851b4efd4c1f0a17ab650a936b740 /net-libs
parentAdded altivec patch from bug #107209. (diff)
downloadhistorical-959bd9b84d4c212aede67a02f8ba8b62b6e34c63.tar.gz
historical-959bd9b84d4c212aede67a02f8ba8b62b6e34c63.tar.bz2
historical-959bd9b84d4c212aede67a02f8ba8b62b6e34c63.zip
Version bump to latest version, drop old version.
Package-Manager: portage-2.1.1_pre2-r6
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog10
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.10.03
-rw-r--r--net-libs/libtorrent/libtorrent-0.10.0.ebuild37
3 files changed, 49 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 82a8fcaa9bb5..ec2373e1b011 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.57 2006/05/23 09:40:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.58 2006/07/08 23:11:33 flameeyes Exp $
+
+*libtorrent-0.10.0 (08 Jul 2006)
+
+ 08 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -files/libtorrent-0.9.0-crash.patch, -libtorrent-0.9.0.ebuild,
+ -libtorrent-0.9.0-r1.ebuild, -libtorrent-0.9.1.ebuild,
+ -libtorrent-0.9.2.ebuild, +libtorrent-0.10.0.ebuild:
+ Version bump to latest version, drop old version.
*libtorrent-0.9.3 (23 May 2006)
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.10.0 b/net-libs/libtorrent/files/digest-libtorrent-0.10.0
new file mode 100644
index 000000000000..0c17222a2f87
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.10.0
@@ -0,0 +1,3 @@
+MD5 240e90818c4c9c34474b2e1873d09910 libtorrent-0.10.0.tar.gz 447795
+RMD160 bb19d7154a7eede2b1c5585563ddf03b608c77ce libtorrent-0.10.0.tar.gz 447795
+SHA256 47645632fee222609c139bddf50872949bd3359214976a25a92bbc1d277c70de libtorrent-0.10.0.tar.gz 447795
diff --git a/net-libs/libtorrent/libtorrent-0.10.0.ebuild b/net-libs/libtorrent/libtorrent-0.10.0.ebuild
new file mode 100644
index 000000000000..88f0222eb849
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.10.0.ebuild,v 1.1 2006/07/08 23:11:33 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}