summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-05 07:19:27 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-05 07:19:27 +0000
commitd94cc7cfcef29e18bb14c5eb4632a7507db73225 (patch)
treeb92982751af2df596de74af2d8eb038d1f3271ce /net-p2p/azureus-bin
parenttidy older versions (diff)
downloadhistorical-d94cc7cfcef29e18bb14c5eb4632a7507db73225.tar.gz
historical-d94cc7cfcef29e18bb14c5eb4632a7507db73225.tar.bz2
historical-d94cc7cfcef29e18bb14c5eb4632a7507db73225.zip
Azureus is a Java based bittorrent client. Initial ebuild provided by me and Andy Daniels <danielsa@uwstout.edu> in bug #35556... only swt interface currently
Diffstat (limited to 'net-p2p/azureus-bin')
-rw-r--r--net-p2p/azureus-bin/ChangeLog14
-rw-r--r--net-p2p/azureus-bin/Manifest6
-rw-r--r--net-p2p/azureus-bin/azureus-bin-2.0.7.1_pre20040224.ebuild140
-rw-r--r--net-p2p/azureus-bin/files/azureus-bin-2.0.7.1_pre20040224-gentoo.sh91
-rw-r--r--net-p2p/azureus-bin/files/azureus-bin-Makefile.patch11
-rw-r--r--net-p2p/azureus-bin/files/digest-azureus-bin-2.0.7.1_pre200402244
-rw-r--r--net-p2p/azureus-bin/metadata.xml5
7 files changed, 271 insertions, 0 deletions
diff --git a/net-p2p/azureus-bin/ChangeLog b/net-p2p/azureus-bin/ChangeLog
new file mode 100644
index 000000000000..3bab22863b39
--- /dev/null
+++ b/net-p2p/azureus-bin/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for net-p2p/azureus-bin
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus-bin/ChangeLog,v 1.4 2004/03/05 07:19:27 eradicator Exp $
+
+*azureus-bin-2.0.7.1_pre20040224 (04 Mar 2004)
+
+ 04 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ azureus-bin-2.0.7.1_pre20040224.ebuild, metadata.xml,
+ files/azureus-bin-2.0.7.1_pre20040224-gentoo.sh,
+ files/azureus-bin-Makefile.patch:
+ Azureus is a Java based bittorrent client. Initial ebuild provided by me and
+ Andy Daniels <danielsa@uwstout.edu> in bug #35556... only swt interface
+ currently
+
diff --git a/net-p2p/azureus-bin/Manifest b/net-p2p/azureus-bin/Manifest
new file mode 100644
index 000000000000..e735c89f531c
--- /dev/null
+++ b/net-p2p/azureus-bin/Manifest
@@ -0,0 +1,6 @@
+MD5 cd09c8e01cd834be4df96e840fcdcc3a azureus-bin-2.0.7.1_pre20040224.ebuild 3517
+MD5 7294b896c0a22835e038ad0ab9abc7f1 ChangeLog 638
+MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
+MD5 492b5db31f8be8a352cc1eb3adb23ba1 files/digest-azureus-bin-2.0.7.1_pre20040224 299
+MD5 a5ae00888f1b5e4910a2005c77002994 files/azureus-bin-2.0.7.1_pre20040224-gentoo.sh 2505
+MD5 17762081fd25f6928b7bd085fa61d9ee files/azureus-bin-Makefile.patch 402
diff --git a/net-p2p/azureus-bin/azureus-bin-2.0.7.1_pre20040224.ebuild b/net-p2p/azureus-bin/azureus-bin-2.0.7.1_pre20040224.ebuild
new file mode 100644
index 000000000000..a37331e19ce9
--- /dev/null
+++ b/net-p2p/azureus-bin/azureus-bin-2.0.7.1_pre20040224.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus-bin/azureus-bin-2.0.7.1_pre20040224.ebuild,v 1.1 2004/03/05 07:19:27 eradicator Exp $
+
+inherit eutils
+
+DESCRIPTION="Azureus - Java BitTorent Client"
+HOMEPAGE="http://azureus.sourceforge.net/"
+
+MY_PN=${PN/-bin/}
+MY_PV=`echo ${PV} | sed 's/_pre.*$//'`
+MY_DT=`echo ${PV} | sed 's/^.*_pre//'`
+MY_JV="${MY_PV}-${MY_DT}"
+
+# The release version we're starting from
+BASE_V="2.0.7.0a"
+
+S=${WORKDIR}/${MY_PN}
+
+SRC_URI="mirror://sourceforge/${MY_PN}/Azureus_${BASE_V}_linux.GTK.tar.bz2
+ mirror://sourceforge/${MY_PN}/Azureus_${BASE_V}_linux.Motif.tar.bz2
+ mirror://gentoo/seda-${MY_DT}.zip
+ mirror://gentoo/Azureus2-${MY_JV}.jar"
+
+RESTRICT="nomirror"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="gtk kde"
+
+DEPEND="kde? ( =x11-libs/qt-3*
+ =kde-base/kdelibs-3* )"
+
+RDEPEND="${DEPEND}
+ dev-java/commons-cli
+ gtk? ( =x11-libs/gtk+-2* )
+ >=virtual/jre-1.4"
+
+# Where to install the package
+PROGRAM_DIR="/usr/lib/${MY_PN}"
+
+src_unpack() {
+ if [ `use gtk` ] ; then
+ unpack Azureus_${BASE_V}_linux.GTK.tar.bz2
+ echo
+ einfo "Using the GTK Azureus package, to use the Motif package"
+ einfo " set USE=\"-gtk\" in /etc/make.conf."
+ echo
+ else
+ unpack Azureus_${BASE_V}_linux.Motif.tar.bz2
+ echo
+ einfo "Using the Motif Azureus package, to use the GTK package"
+ einfo " set USE=\"gtk\" in /etc/make.conf."
+ echo
+
+ # Delete these links so they don't mess us up in install
+ # Links are remade later in the installation
+ rm ${S}/libXm.so
+ rm ${S}/libXm.so.2
+ fi
+
+ cp ${DISTDIR}/Azureus2-${MY_JV}.jar ${S}/Azureus2.jar
+
+ # Patch cleans up Makefile
+ epatch ${FILESDIR}/${PN}-Makefile.patch
+
+ cp ${FILESDIR}/${P}-gentoo.sh ${S}/azureus
+
+ if [ ! `use kde` ] ; then
+ sed -i "s:ON=TRUE:ON=FALSE:" ${MY_PN}/azureus
+ fi
+
+ # Set runtime settings in the startup script
+ sed -i "s:##PROGRAM_DIR##:${PROGRAM_DIR}:" ${MY_PN}/azureus
+
+ # Unpack seda
+ cd ${S}
+ unpack seda-${MY_DT}.zip
+ tar xjf seda-jnilibs-linux.tar.bz2
+ rm seda*bz2
+}
+
+src_compile() {
+ if [ `use kde` ] ; then
+ cd ${S}/systray4jdaemon
+ emake || die
+ fi
+}
+
+src_install() {
+ cd ${S}
+
+ insinto ${PROGRAM_DIR}
+ exeinto ${PROGRAM_DIR}
+
+ doins *.jar id.azureus.dir.file
+ doexe *.so
+
+ # This only needs to be run when using the Motif package
+ if [ ! `use gtk` ] ; then
+ doexe libXm.so.2.1
+ dosym libXm.so.2.1 ${PROGRAM_DIR}/libXm.so
+ dosym libXm.so.2.1 ${PROGRAM_DIR}/libXm.so.2
+ fi
+
+ if [ `use kde` ] ; then
+ doexe systray4jdaemon/systray4jd
+ fi
+
+ dobin azureus
+
+ dodoc README.linux seda-README.txt
+}
+
+pkg_postinst() {
+ echo
+ einfo "Due to the nature of the portage system, we recommend"
+ einfo "that users check portage for new versions of Azureus"
+ einfo "instead of attempting to use the auto-update feature."
+ echo
+ einfo "After running azureus for the first time, configuration"
+ einfo "options will be placed in ~/.azureus/gentoo.config"
+ einfo "It is recommended that you modify this file rather than"
+ einfo "the azureus startup script directly."
+ echo
+
+ if [ `use kde` ] ; then
+ einfo "The KDE system tray daemon has been built with your"
+ einfo "installation. To disable this feature you must modify"
+ einfo "~/.azureus/gentoo.config after running azureus for the"
+ einfo "first time."
+ echo
+ fi
+
+ einfo "Currently, only the swt interface is usable. Please comment"
+ einfo "at http://bugs.gentoo.org/show_bug.cgi?id=35556 if you have a"
+ einfo "fix for the other interfaces."
+}
diff --git a/net-p2p/azureus-bin/files/azureus-bin-2.0.7.1_pre20040224-gentoo.sh b/net-p2p/azureus-bin/files/azureus-bin-2.0.7.1_pre20040224-gentoo.sh
new file mode 100644
index 000000000000..fc35067c86da
--- /dev/null
+++ b/net-p2p/azureus-bin/files/azureus-bin-2.0.7.1_pre20040224-gentoo.sh
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+PROGRAM_DIR=##PROGRAM_DIR## # directory where all the files were extracted
+
+AZ_CONFIG="${HOME}/.azureus/gentoo.config"
+if [ -f ~/.azureus/gentoo.config ]; then
+ . ~/.azureus/gentoo.config
+else
+ if [ ! -e ~/.azureus ]; then
+ mkdir ~/.azureus
+ echo "Creating ~/.azureus..."
+ fi
+
+ # Setup defaults
+ KDE_SYSTRAY4J_DAEMON=TRUE
+ UI_OPTIONS="--ui=swt"
+
+ # Create the config file
+ cat > ${AZ_CONFIG} <<END
+# KDE_SYSTRAY4J_DAEMON: TRUE or FALSE to enable/disable the KDE systray icon.
+KDE_SYSTRAY4J_DAEMON=${KDE_SYSTRAY4J_DAEMON}
+
+# User Interface options:
+# web - web based
+# web2 - web based
+# console - console based
+# swt - swt (GUI) based
+#
+# When selecting just 1, use '--ui=<ui>'
+# When selecting multiple, use '--uis=<ui>,<ui>'
+UI_OPTIONS="--ui=swt"
+END
+
+fi
+
+MSG0="ERROR:\nYou must edit this script and change PROGRAM_DIR to point to where you installed Azureus"
+MSG1="Attempting to start systray4j KDE daemon..."
+MSG2="Systray4j daemon started"
+MSG3="Starting for first time: attempting to compile and link..."
+MSG4="Compile and link successful"
+MSG5="Compile and link FAILED: to fix, please read "
+MSG6="Unable to locate systray4jd source files"
+MSG7="Systray4j daemon detected already running"
+MSG8="Attempting to start Azureus..."
+
+AZDIR=./
+if [ ! -e id.azureus.dir.file ]; then
+ AZDIR=$PROGRAM_DIR
+ if [ ! -d $AZDIR ]; then
+ echo $MSG0
+ exit -1
+ fi
+fi
+
+cd ${AZDIR}
+
+#should we attempt to load systray4j daemon ?
+if [ "$KDE_SYSTRAY4J_DAEMON" == "TRUE" ]; then
+ echo $MSG1
+ #check to make sure it is not already running
+ runcount=`ps -ef | grep -v grep | grep -c systray4jd`
+ if `test $runcount = 0` ; then
+ ./systray4jd&
+ else
+ echo $MSG7
+ fi
+fi
+
+echo $MSG8
+
+# DOESN'T WORK
+#JARS=`ls *.jar | grep -v Azureus2`
+#for FILE in $JARS; do CLASSPATH="${FILE}:${CLASSPATH}"; done
+#java -cp $CLASSPATH -Djava.library.path="${AZDIR}" -jar Azureus2.jar ${UI_OPTIONS} "$1"
+
+# WORKS, BUT ONLY SWT
+for FILE in *.jar; do CLASSPATH="${FILE}:${CLASSPATH}"; done
+java -cp $CLASSPATH -Djava.library.path="${AZDIR}" org.gudy.azureus2.ui.swt.Main "$1"
+
+if [ $? -ne 0 ]; then
+ echo "If you recieved an error about missing log4j or cli, you "
+ echo "need to setup your classpath correctly."
+ echo "This should do the trick (as root):"
+ echo "java-config --add-system-classpath=junit,log4j,commons-cli"
+ echo "env-update && source /etc/profile"
+fi
+
+proc_id=`ps -ef | grep -v grep | grep systray4jd | awk '{print $2}'`
+if [ ! "$proc_id" == "" ] ; then
+ kill -9 $proc_id
+fi
diff --git a/net-p2p/azureus-bin/files/azureus-bin-Makefile.patch b/net-p2p/azureus-bin/files/azureus-bin-Makefile.patch
new file mode 100644
index 000000000000..9905e96cb165
--- /dev/null
+++ b/net-p2p/azureus-bin/files/azureus-bin-Makefile.patch
@@ -0,0 +1,11 @@
+--- azureus/systray4jdaemon/Makefile.orig 2003-05-05 15:27:55.000000000 -0500
++++ azureus/systray4jdaemon/Makefile 2004-02-22 21:15:14.944061448 -0600
+@@ -1,6 +1,6 @@
+ # change the following lines according to your distribution
+-QT3_PATH = /usr/lib/qt3
+-KDE3_PATH = /opt/kde3
++QT3_PATH = $(QTDIR)
++KDE3_PATH = $(KDEDIR)
+
+ CPPFLAGS = -DQT_THREAD_SUPPORT -I $(QT3_PATH)/include -I $(KDE3_PATH)/include
+
diff --git a/net-p2p/azureus-bin/files/digest-azureus-bin-2.0.7.1_pre20040224 b/net-p2p/azureus-bin/files/digest-azureus-bin-2.0.7.1_pre20040224
new file mode 100644
index 000000000000..fd17a922f10d
--- /dev/null
+++ b/net-p2p/azureus-bin/files/digest-azureus-bin-2.0.7.1_pre20040224
@@ -0,0 +1,4 @@
+MD5 0799cc2c7a8dc1e32bcc7524984de5aa Azureus_2.0.7.0a_linux.GTK.tar.bz2 2718698
+MD5 3aa84aa0f4970402612e4f21c380abf1 Azureus_2.0.7.0a_linux.Motif.tar.bz2 3629906
+MD5 5f79ac344851884646166d733b5cde8d seda-20040224.zip 755126
+MD5 af980920af1e20da243fbb42875dcf09 Azureus2-2.0.7.1-20040224.jar 2035933
diff --git a/net-p2p/azureus-bin/metadata.xml b/net-p2p/azureus-bin/metadata.xml
new file mode 100644
index 000000000000..aa0f3664825f
--- /dev/null
+++ b/net-p2p/azureus-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+</pkgmetadata>