summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-03-07 15:28:31 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-03-07 15:28:31 +0000
commit331126988cc859b0fd03ae2349d847a51000ce85 (patch)
treeab89043b6e6c5b3ea018c177973346ab1b8dee30 /net-print/gimp-print-cups
parentinitial release (diff)
downloadhistorical-331126988cc859b0fd03ae2349d847a51000ce85.tar.gz
historical-331126988cc859b0fd03ae2349d847a51000ce85.tar.bz2
historical-331126988cc859b0fd03ae2349d847a51000ce85.zip
added 4.3.10 (with gtk+-1.2 dep bug #14945)
Diffstat (limited to 'net-print/gimp-print-cups')
-rw-r--r--net-print/gimp-print-cups/ChangeLog6
-rw-r--r--net-print/gimp-print-cups/files/digest-gimp-print-cups-4.3.101
-rw-r--r--net-print/gimp-print-cups/gimp-print-cups-4.3.10.ebuild72
3 files changed, 78 insertions, 1 deletions
diff --git a/net-print/gimp-print-cups/ChangeLog b/net-print/gimp-print-cups/ChangeLog
index 931a6b07b0d1..1c0ad56567aa 100644
--- a/net-print/gimp-print-cups/ChangeLog
+++ b/net-print/gimp-print-cups/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for net-print/gimp-print-cups
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gimp-print-cups/ChangeLog,v 1.14 2003/03/05 17:25:39 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gimp-print-cups/ChangeLog,v 1.15 2003/03/07 15:28:31 lordvan Exp $
*gimp-print-cups-4.3.11 (05 Mar 2003)
05 Mar 2003; Thomas Raschbacher <lordvan@gentoo.org> gimp-print-cups-4.3.11.ebuild:
new version ~arch + package.masked(because it breaks ghostscript)
+ 07 Mar 2003; Thomas Raschbacher <lordvan@gentoo.org> gimp-print-cups-4.3.10.ebuild:
+ added 4.3.10 for testing
+ added gtk+ dep for 4.3.10 since it seems to require it (bug #14945)
+
*gimp-print-cups-4.3.8 (28 Jan 2003)
28 Jan 2003; Thomas Raschbacher <lordvan@gentoo.org> gimp-print-cups-4.3.8.ebuild:
new version (bug #14661) ~arch
diff --git a/net-print/gimp-print-cups/files/digest-gimp-print-cups-4.3.10 b/net-print/gimp-print-cups/files/digest-gimp-print-cups-4.3.10
new file mode 100644
index 000000000000..c71a0bb79456
--- /dev/null
+++ b/net-print/gimp-print-cups/files/digest-gimp-print-cups-4.3.10
@@ -0,0 +1 @@
+MD5 7178bfd7a88e40018033c4608550074e gimp-print-4.3.10.tar.bz2 3926954
diff --git a/net-print/gimp-print-cups/gimp-print-cups-4.3.10.ebuild b/net-print/gimp-print-cups/gimp-print-cups-4.3.10.ebuild
new file mode 100644
index 000000000000..f80e1870b5b6
--- /dev/null
+++ b/net-print/gimp-print-cups/gimp-print-cups-4.3.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gimp-print-cups/gimp-print-cups-4.3.10.ebuild,v 1.1 2003/03/07 15:28:31 lordvan Exp $
+
+IUSE="nls gtk readline"
+
+MY_PN=${PN/-cups/}
+
+DESCRIPTION="The Common Unix Printing System - Gimp Print Drivers"
+HOMEPAGE="http://gimp-print.sourceforge.net"
+KEYWORDS="~x86 ~ppc"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}-${PV}.tar.bz2"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+DEPEND=">=net-print/cups-1.1.18
+ >=net-print/foomatic-2.0.2
+ media-gfx/imagemagick
+ sys-libs/readline
+ sys-devel/perl
+ =x11-libs/gtk+-1.2*"
+#gtk? ( =x11-libs/gtk+-1.2* ) bug #14945
+
+LICENSE="GPL-2"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use readline \
+ && myconf="${myconf} --enable-readline" \
+ || myconf="${myconf} --disable-readline"
+
+ use gtk \
+ && myconf="${myconf} --enable-lexmarkutil" \
+ || myconf="${myconf} --disable-lexmarkutil"
+
+ #--without-translated-ppds \
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib \
+ --infodir=/usr/share/info \
+ --with-cups \
+ --enable-test \
+ --with-samples \
+ --without-gimp \
+ --with-escputil \
+ --with-foomatic \
+ --with-testpattern \
+ --with-user-guide \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+
+ emake || die "compile problem"
+# patch src/main/gimpprint.m4 < ${FILESDIR}/gimpprint.m4.patch || die
+}
+
+src_install () {
+ make install DESTDIR=${D} || die
+
+ exeinto /usr/share/gimp-print
+ doexe test/{unprint,pcl-unprint,bjc-unprint,parse-escp2,parse-bjc}
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README \
+ doc/gimpprint.ps
+ dohtml doc/manual-html doc/FAQ.html
+}