summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-22 20:23:40 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-22 20:23:40 +0000
commit7324e58dc05e6a809771f5c4dabd4bdc21bd5a98 (patch)
treee1bba72174b41f189f18d250674e7283e410fedd /sci-chemistry/coot
parentremoved old versions (diff)
downloadhistorical-7324e58dc05e6a809771f5c4dabd4bdc21bd5a98.tar.gz
historical-7324e58dc05e6a809771f5c4dabd4bdc21bd5a98.tar.bz2
historical-7324e58dc05e6a809771f5c4dabd4bdc21bd5a98.zip
Fixes for Python ABIs
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/coot')
-rw-r--r--sci-chemistry/coot/ChangeLog5
-rw-r--r--sci-chemistry/coot/coot-0.6.ebuild8
2 files changed, 9 insertions, 4 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index d55b9dc392a3..da7ac5185ead 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/coot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.21 2010/02/26 19:02:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.22 2010/04/22 20:23:40 jlec Exp $
+
+ 22 Apr 2010; Justin Lecher <jlec@gentoo.org> coot-0.6.ebuild:
+ Fixes for Python ABIs
26 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net> coot-0.6.ebuild:
Missing sci-libs/mmdb DEP added
diff --git a/sci-chemistry/coot/coot-0.6.ebuild b/sci-chemistry/coot/coot-0.6.ebuild
index c72e7792b962..ed3499c2821e 100644
--- a/sci-chemistry/coot/coot-0.6.ebuild
+++ b/sci-chemistry/coot/coot-0.6.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.ebuild,v 1.2 2010/02/26 19:02:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.ebuild,v 1.3 2010/04/22 20:23:40 jlec Exp $
EAPI="3"
-inherit autotools base versionator
+PYTHON_DEPEND="2"
+
+inherit autotools base python versionator
MY_S2_PV=$(replace_version_separator 2 - ${PV})
MY_S2_P=${PN}-${MY_S2_PV/pre1/pre-1}
@@ -95,7 +97,7 @@ src_configure() {
src_compile() {
emake || die "emake failed"
-
+ python_convert_shebangs $(python_get_version) src/coot_gtk2.py
cp "${S}"/src/coot_gtk2.py python/coot.py || die
}