summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-21 14:33:53 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-21 14:33:53 +0000
commit3acd787f2f2b3dd1fec38b441a76205b0b799a0e (patch)
treeb4e3cf533ebac70e33bd0ceb018e59f45a9c3148 /sci-chemistry/ghemical/ghemical-2.99.2.ebuild
parentMasking =sci-electronics/geda-1.4.3-r1 for QA removal. (diff)
downloadhistorical-3acd787f2f2b3dd1fec38b441a76205b0b799a0e.tar.gz
historical-3acd787f2f2b3dd1fec38b441a76205b0b799a0e.tar.bz2
historical-3acd787f2f2b3dd1fec38b441a76205b0b799a0e.zip
Version Bump, fixing bug 212689, 232292, 246414, thanks rei4dan for working on patches, Cleaned old buggy versions, Fixed wrong path for html installation
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/ghemical/ghemical-2.99.2.ebuild')
-rw-r--r--sci-chemistry/ghemical/ghemical-2.99.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-chemistry/ghemical/ghemical-2.99.2.ebuild b/sci-chemistry/ghemical/ghemical-2.99.2.ebuild
new file mode 100644
index 000000000000..9aec8849a252
--- /dev/null
+++ b/sci-chemistry/ghemical/ghemical-2.99.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ghemical-2.99.2.ebuild,v 1.1 2010/06/21 14:33:53 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="openbabel seamonkey threads"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/libglade
+ sci-chemistry/mpqc
+ >=sci-libs/libghemical-2.99
+ >=x11-libs/liboglappth-0.98
+ virtual/opengl
+ x11-libs/pango
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ openbabel? ( sci-chemistry/openbabel )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-docs.patch
+ eautoreconf
+}
+
+src_configure() {
+# With amd64, if you want gamess I recommend adding gamess and gtk-gamess to package.provided for now.
+
+# Change the built-in help browser.
+ if use seamonkey ; then
+ sed -i -e 's|mozilla|seamonkey|g' src/gtk_app.cpp || die "sed failed for seamonkey!"
+ else
+ sed -i -e 's|mozilla|firefox|g' src/gtk_app.cpp || die "sed failed for firefox!"
+ fi
+
+ econf \
+ $(use_enable openbabel) \
+ $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}