summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-04-19 01:00:39 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-04-19 01:00:39 +0000
commit8dc1c0fd7e85373e664c2cf41c1167dc27686037 (patch)
treef1d8bc99684267fe84d494e776816d7d3fcc9d2f /sci-libs
parentVersion bump, mostly bugfixes. (diff)
downloadhistorical-8dc1c0fd7e85373e664c2cf41c1167dc27686037.tar.gz
historical-8dc1c0fd7e85373e664c2cf41c1167dc27686037.tar.bz2
historical-8dc1c0fd7e85373e664c2cf41c1167dc27686037.zip
New ebuild for OPeNDAP C++ library, a required dependency for ferret.
Package-Manager: portage-2.2_rc30/cvs/Linux x86_64
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libdap/ChangeLog10
-rw-r--r--sci-libs/libdap/Manifest4
-rw-r--r--sci-libs/libdap/libdap-3.9.2.ebuild51
-rw-r--r--sci-libs/libdap/metadata.xml16
4 files changed, 81 insertions, 0 deletions
diff --git a/sci-libs/libdap/ChangeLog b/sci-libs/libdap/ChangeLog
new file mode 100644
index 000000000000..0464c4930fd4
--- /dev/null
+++ b/sci-libs/libdap/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/libdap
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/ChangeLog,v 1.1 2009/04/19 01:00:39 nerdboy Exp $
+
+*libdap-3.9.2 (19 Apr 2009)
+
+ 19 Apr 2009; Steve Arnold <nerdboy@gentoo.org> +metadata.xml,
+ +libdap-3.9.2.ebuild:
+ New ebuild for OPeNDAP C++ library, a required dependency for ferret.
+
diff --git a/sci-libs/libdap/Manifest b/sci-libs/libdap/Manifest
new file mode 100644
index 000000000000..2bd42051c148
--- /dev/null
+++ b/sci-libs/libdap/Manifest
@@ -0,0 +1,4 @@
+DIST libdap-3.9.2.tar.gz 1344265 RMD160 17fd35fd1e81b6ab3d84a4401583f510820d5601 SHA1 38460059cf85b5ceec377be8b97e3202047b3696 SHA256 5e925c274128a4d220e7d6afeaa37132d0b98e0bf30c680c7cb8cca2b9b3f5ed
+EBUILD libdap-3.9.2.ebuild 1175 RMD160 599dbd6363df3d26b9c8a6ac62ce8887122b2fbc SHA1 ae7230695343187b06d0b6f4a5c3be69f5200cdc SHA256 3a7186f07443b618f43aad204c282c6aedac2eac180d995c951f476052a9680a
+MISC ChangeLog 394 RMD160 a3912ad6c69cac561f49a64c3e88b9d6f6703041 SHA1 4c04fd70f3018e821df71dd009f6dcfc890f5991 SHA256 95e0714b1ce227f85e9f502faa47b6d1a4e104a4df9dddb75412a88946a96b87
+MISC metadata.xml 737 RMD160 c8195a9a8025b42fa6b9b002853f8e0d28f40ef3 SHA1 06f58d0f6cc5060d2ab8bfa68851b3b17cfdc9bc SHA256 8c6dcedc7fc648b0b967e2e4b35a3f1636aff200535463ecdb245cd0d9e0dcfd
diff --git a/sci-libs/libdap/libdap-3.9.2.ebuild b/sci-libs/libdap/libdap-3.9.2.ebuild
new file mode 100644
index 000000000000..dd9289e32c9c
--- /dev/null
+++ b/sci-libs/libdap/libdap-3.9.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/libdap-3.9.2.ebuild,v 1.1 2009/04/19 01:00:39 nerdboy Exp $
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="A C++ SDK which contains an implementation of DAP 2.0 and 3.2, both Client- and Server-side support."
+HOMEPAGE="http://opendap.org/index.html"
+SRC_URI="http://www.opendap.org/pub/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-util/cppunit
+ dev-util/dejagnu"
+
+DEPEND="${RDEPEND}
+ sys-libs/zlib
+ >=dev-libs/libxml2-2.5.7
+ >=net-misc/curl-7.10.6
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eaclocal
+ eautoreconf
+}
+
+src_compile() {
+ local myconf="--disable-dependency-tracking"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc; then
+ make docs || die "make docs failed"
+ fi
+}
+
+src_test() {
+ make check || die "make check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README NEWS README.dodsrc README.AIS
+ use doc && dohtml docs/html/*
+}
diff --git a/sci-libs/libdap/metadata.xml b/sci-libs/libdap/metadata.xml
new file mode 100644
index 000000000000..4bbe0bb1adb6
--- /dev/null
+++ b/sci-libs/libdap/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-geosciences</herd>
+<maintainer>
+ <email>nerdboy@gentoo.org</email>
+</maintainer>
+<longdescription>
+libdap is a C++ implementation of OPeNDAP which allows access to data over the
+internet, from programs that weren't originally designed for that purpose, as
+well as some that were. While OPeNDAP is the original developer of the Data
+Access Protocol (DAP) which it's software uses, many other groups have adopted
+DAP and provide compatible clients, servers and software development kits.
+DAP is a NASA community standard: http://www.esdswg.org/spg/rfc/ese-rfc-004
+</longdescription>
+</pkgmetadata>