summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-20 17:47:25 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-20 17:47:25 +0000
commit9f7d521b9d1e45937a58e0062810edb9c9105086 (patch)
tree2058d86434482e8161a4fd3995ca8ceb87aa7f2b /sys-devel
parentStable on hppa, mips, ppc, sparc, x86. (diff)
downloadhistorical-9f7d521b9d1e45937a58e0062810edb9c9105086.tar.gz
historical-9f7d521b9d1e45937a58e0062810edb9c9105086.tar.bz2
historical-9f7d521b9d1e45937a58e0062810edb9c9105086.zip
add sanity check to make sure people dont try creating a cross-compiler with same name as native target
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/Manifest8
-rwxr-xr-xsys-devel/crossdev/files/crossdev8
2 files changed, 11 insertions, 5 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 8996419c885f..5a60e7afc1f3 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -3,13 +3,13 @@ Hash: SHA1
MD5 582c83b33545f1de39861e08f42859e2 ChangeLog 5215
MD5 091fb844f716a3f89969a7c6cc9a5eea crossdev-0.9.9-r3.ebuild 596
-MD5 fa240cdd507d211befcfc5b0260484ab files/crossdev 13247
+MD5 11bb3ab1c1cb464c1bf5cc77fbc7fbc7 files/crossdev 13430
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-crossdev-0.9.9-r3 0
MD5 e91cdaf464f515f3528da02cf06e54a1 metadata.xml 222
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDUi1/gIKl8Uu19MoRAglRAJ4idOWjCn/dECgizpfLug8vry3lpwCfc+9y
-nfQB4KjdSLhA75fm+FwJdWA=
-=ZYlt
+iD8DBQFDV9jVgIKl8Uu19MoRAgH8AJ46P+ewVdLGcUVA+Fxfo6USUPX2zgCfa6iy
+Lx+4YVlu5qL/Vv58q3WlTFI=
+=gyFw
-----END PGP SIGNATURE-----
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index 6db314d1859f..69c7378de173 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.39 2005/10/16 10:35:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.40 2005/10/20 17:47:25 vapier Exp $
cd /
@@ -323,6 +323,12 @@ if [[ -z ${PORTDIR_OVERLAY} ]] ; then
exit 1
fi
+if [[ $(env -u CHOST portageq envvar CHOST) == ${CTARGET} ]] ; then
+ eerror "Refusing to create a cross-compiler using the same"
+ eerror "target name as your host utils."
+ exit 1
+fi
+
#####################
### do the emerge ###
(