summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-25 08:50:25 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-25 08:50:25 +0000
commitbaff094d1116ffc95e6f57cc770382201aadadbd (patch)
treec805c9f42a9eb0ec29893f0de551b2dd93be90a1 /www-apps/phpsysinfo/phpsysinfo-3.1.12.ebuild
parentVersion bump. (diff)
downloadhistorical-baff094d1116ffc95e6f57cc770382201aadadbd.tar.gz
historical-baff094d1116ffc95e6f57cc770382201aadadbd.tar.bz2
historical-baff094d1116ffc95e6f57cc770382201aadadbd.zip
Version bump.
Package-Manager: portage-2.2.10/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'www-apps/phpsysinfo/phpsysinfo-3.1.12.ebuild')
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.1.12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.1.12.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.1.12.ebuild
new file mode 100644
index 000000000000..c059e6c2a888
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.1.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpsysinfo/phpsysinfo-3.1.12.ebuild,v 1.1 2014/04/25 08:50:22 radhermit Exp $
+
+EAPI=5
+
+inherit webapp
+
+DESCRIPTION="phpSysInfo is a nice package that will display your system stats via PHP"
+HOMEPAGE="http://rk4an.github.com/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+RDEPEND="virtual/httpd-php
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore .travis.yml || die
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ newins phpsysinfo.ini{.new,}
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+ webapp_src_install
+}