summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
commitca2ca9b65bbc3ab8ee486afb137316bc97db3903 (patch)
tree42d6b7ee1bcc94d68f654ae21c12dcb794558d69 /x11-libs/dnd
parentperl testing on ppc; added positive test results (diff)
downloadhistorical-ca2ca9b65bbc3ab8ee486afb137316bc97db3903.tar.gz
historical-ca2ca9b65bbc3ab8ee486afb137316bc97db3903.tar.bz2
historical-ca2ca9b65bbc3ab8ee486afb137316bc97db3903.zip
modernised
Diffstat (limited to 'x11-libs/dnd')
-rw-r--r--x11-libs/dnd/dnd-1.1.ebuild33
1 files changed, 11 insertions, 22 deletions
diff --git a/x11-libs/dnd/dnd-1.1.ebuild b/x11-libs/dnd/dnd-1.1.ebuild
index c89ba96d8859..7119e228a011 100644
--- a/x11-libs/dnd/dnd-1.1.ebuild
+++ b/x11-libs/dnd/dnd-1.1.ebuild
@@ -1,40 +1,29 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/dnd-1.1.ebuild,v 1.5 2002/08/01 11:40:16 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/dnd/dnd-1.1.ebuild,v 1.6 2002/08/05 10:02:51 seemant Exp $
S=${WORKDIR}/DND/DNDlib
-
DESCRIPTION="OffiX' Drag'n'drop library"
-
+HOMEPAGE="http://leb.net/OffiX"
SRC_URI="http://leb.net/OffiX/dnd.1.1.tgz"
-LICENSE="GPL-2 LGPL-2"
+
SLOT="0"
+LICENSE="GPL-2 LGPL-2"
KEYWORDS="x86"
-HOMEPAGE="http://leb.net/OffiX"
-
-DEPEND="virtual/glibc virtual/x11"
+DEPEND="virtual/x11"
src_unpack() {
-
- unpack dnd.1.1.tgz
- cd ${S}
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
-
+ unpack dnd.1.1.tgz
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die
}
src_compile() {
- ./configure --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --prefix=/usr \
- --with-x \
- --host=${CHOST} || die
- emake || die
+ econf --with-x || die
+ emake || die
}
src_install () {
-
- make prefix=${D}/usr install || die
-
+ make prefix=${D}/usr install || die
}
-