summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/struts-legacy/ChangeLog9
-rw-r--r--dev-java/struts-legacy/Manifest14
-rw-r--r--dev-java/struts-legacy/struts-legacy-1.0-r1.ebuild8
3 files changed, 24 insertions, 7 deletions
diff --git a/dev-java/struts-legacy/ChangeLog b/dev-java/struts-legacy/ChangeLog
index f8895620395b..c09ea6450c1c 100644
--- a/dev-java/struts-legacy/ChangeLog
+++ b/dev-java/struts-legacy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/struts-legacy
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/struts-legacy/ChangeLog,v 1.8 2004/10/17 07:32:04 absinthe Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/struts-legacy/ChangeLog,v 1.9 2005/03/16 15:30:13 luckyduck Exp $
+
+ 16 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ struts-legacy-1.0-r1.ebuild:
+ added has_version jdbc2-stdext call to avoid error messages, depend on
+ jdbc2-stdext is conditional. fixes #85415
17 Oct 2004; Dylan Carlson <absinthe@gentoo.org>
struts-legacy-1.0-r1.ebuild:
diff --git a/dev-java/struts-legacy/Manifest b/dev-java/struts-legacy/Manifest
index 5c8a6d2beeb5..44b3eb1884ab 100644
--- a/dev-java/struts-legacy/Manifest
+++ b/dev-java/struts-legacy/Manifest
@@ -1,4 +1,14 @@
-MD5 94c84c43079452daf0669de791d3481e ChangeLog 1339
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 21515fa2c5cabec709d63f43ae887695 struts-legacy-1.0-r1.ebuild 1304
+MD5 e17bd55321b2ada592116d9571a8b101 ChangeLog 1541
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
-MD5 a5875b655a533a901a44f8c0a0e314d2 struts-legacy-1.0-r1.ebuild 1263
MD5 2459923e54f157c4320980a9c75c49e1 files/digest-struts-legacy-1.0-r1 72
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCOFEL06ebR+OMO78RAnRdAJwK5uA+xG4FvYOQK9OYH6fZDvkeAACgkF2O
+w+/ImRyVscoUIzQhj1atJWs=
+=7noU
+-----END PGP SIGNATURE-----
diff --git a/dev-java/struts-legacy/struts-legacy-1.0-r1.ebuild b/dev-java/struts-legacy/struts-legacy-1.0-r1.ebuild
index 3a537ebc0962..d7a4885163a6 100644
--- a/dev-java/struts-legacy/struts-legacy-1.0-r1.ebuild
+++ b/dev-java/struts-legacy/struts-legacy-1.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/struts-legacy/struts-legacy-1.0-r1.ebuild,v 1.7 2004/10/17 07:32:04 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/struts-legacy/struts-legacy-1.0-r1.ebuild,v 1.8 2005/03/16 15:30:13 luckyduck Exp $
inherit java-pkg
@@ -25,7 +25,9 @@ S=${WORKDIR}/${P}-src
src_compile() {
sed -i 's:compile,docs:compile:' build.xml || die "sed failed"
echo "commons-logging.jar=`java-config -p commons-logging | sed 's/.*://'`" > build.properties
- echo "jdbc20ext.jar=`java-config -p jdbc2-stdext`" >> build.properties
+ if has_version jdbc2-stdext; then
+ echo "jdbc20ext.jar=`java-config -p jdbc2-stdext`" >> build.properties
+ fi
echo "jdk.version=1.4" >> build.properties
local antflags="dist"