summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/sandbox/ChangeLog7
-rw-r--r--sys-apps/sandbox/Manifest14
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.41
-rw-r--r--sys-apps/sandbox/sandbox-1.2.4.ebuild86
4 files changed, 106 insertions, 2 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 34a009d6f613..34b214253483 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.8 2005/04/29 13:47:44 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.9 2005/05/03 11:21:04 azarah Exp $
+
+*sandbox-1.2.4 (03 May 2005)
+
+ 03 May 2005; Martin Schlemmer <azarah@gentoo.org> +sandbox-1.2.4.ebuild:
+ Some speedups (bug #91040) and uclibc fixes.
*sandbox-1.2.3 (29 Apr 2005)
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index 6bb6894deab7..a168556c2fcb 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,6 +1,18 @@
-MD5 a50e5f3564cb919dea831675066e0205 ChangeLog 1216
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 ad9dd0f6bf1d6a38d3e03b394c0966f3 ChangeLog 1369
MD5 968e2965b0b6f620634dae6d28d8b4c4 metadata.xml 455
+MD5 7ed1125d24e2a98b0832f84d9ab637da sandbox-1.2.4.ebuild 2145
MD5 3c85f7c72e45afadde1025fc0ef3a205 sandbox-1.2.2.ebuild 2235
MD5 734eba450db4538f0e38ee876d28dacc sandbox-1.2.3.ebuild 2145
+MD5 608cba289865ac916fb83ba5dc9daa2f files/digest-sandbox-1.2.4 66
MD5 fb651b249c3214a6d0fa321e1d419e07 files/digest-sandbox-1.2.2 66
MD5 bf2c5f346fcc11659401c9240b1b8db9 files/digest-sandbox-1.2.3 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCd1/n1ZcsMnZjRyIRAjkPAJ955XVGXc5CIyh4pzTJiM8dpODmrQCcCrpB
+fDbjCWAu0Gp/SoBBW/8vajE=
+=Hr4o
+-----END PGP SIGNATURE-----
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.4 b/sys-apps/sandbox/files/digest-sandbox-1.2.4
new file mode 100644
index 000000000000..fa56570c7f62
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.4
@@ -0,0 +1 @@
+MD5 91d0c2345a2dd3e630c2cfbb137ba9ef sandbox-1.2.4.tar.bz2 221626
diff --git a/sys-apps/sandbox/sandbox-1.2.4.ebuild b/sys-apps/sandbox/sandbox-1.2.4.ebuild
new file mode 100644
index 000000000000..6aff8b52261f
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.4.ebuild,v 1.1 2005/05/03 11:21:04 azarah Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS=" alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+RESTRICT="multilib-pkg-force"
+
+DEPEND="virtual/libc"
+
+check_multilib() {
+ has_m32
+ if [ "$?" == 0 ] ; then
+ einfo "Found valid multilib environment."
+ einfo "Building with multilib support."
+ export MULTILIB="1"
+ else
+ ewarn "No valid multilib environment found!"
+ ewarn "Building without multilib support. If"
+ ewarn "you want to have multilib support,"
+ ewarn "emerge gcc with \"multilib\" in your"
+ ewarn "useflags."
+ fi
+}
+
+src_unpack() {
+ if has_multilib_profile ; then
+ for TA in $(get_install_abis); do
+ unpack ${A}
+ cd ${WORKDIR}
+ mv ${S} ${S%/}-${TA} || die "failed mving \$S to $TA"
+ done
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ filter-lfs-flags #90228
+ if has_multilib_profile ; then
+ OABI="${ABI}"
+ export CFLAGS="${CFLAGS} -DSB_HAVE_64BIT_ARCH"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ econf --libdir="/usr/$(get_libdir)" || die "econf failed for $ABI"
+ emake || die "emake failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ if useq amd64 ; then
+ check_multilib
+ export HAVE_64BIT_ARCH="${MULTILIB}"
+ fi
+ econf || die "econf failed"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ if has_multilib_profile; then
+ OABI="${ABI}"
+ for ABI in $(get_install_abis); do
+ export ABI
+ cd ${S}-${ABI}
+ make DESTDIR="${D}" install || die "make install failed for $ABI"
+ done
+ ABI="${OABI}"
+ else
+ make install DESTDIR="${D}" || die "einstalled failed"
+ fi
+}