summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/joe/ChangeLog9
-rw-r--r--app-editors/joe/Manifest12
-rw-r--r--app-editors/joe/files/digest-joe-3.0-r21
-rw-r--r--app-editors/joe/files/digest-joe-3.1-r11
-rw-r--r--app-editors/joe/files/joe-3.0-overflow.patch12
-rw-r--r--app-editors/joe/files/joe-3.1-overflow.patch12
-rw-r--r--app-editors/joe/joe-3.0-r2.ebuild (renamed from app-editors/joe/joe-3.0-r1.ebuild)6
-rw-r--r--app-editors/joe/joe-3.1-r1.ebuild (renamed from app-editors/joe/joe-3.1.ebuild)6
8 files changed, 49 insertions, 10 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index 94b778016207..854447fecf39 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/joe
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.27 2004/10/13 17:57:23 tomk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.28 2004/11/22 13:32:11 tomk Exp $
+
+*joe-3.1-r1 (22 Nov 2004)
+
+ 22 Nov 2004; Tom Knight <tomk@gentoo.org> -joe-3.0-r1.ebuild,
+ +joe-3.0-r2.ebuild, +joe-3.1-r1.ebuild, -joe-3.1.ebuild:
+ Fixed non-critical buffer overflow, closes bug #71129. Changed einstall to
+ make install, closes bug #72023
*joe-3.1 (13 Oct 2004)
diff --git a/app-editors/joe/Manifest b/app-editors/joe/Manifest
index 08080fd17829..2f8a3488d511 100644
--- a/app-editors/joe/Manifest
+++ b/app-editors/joe/Manifest
@@ -1,6 +1,8 @@
-MD5 6a6c1e09a509e29d16236b1253a72256 joe-3.0-r1.ebuild 1319
-MD5 cf317fb3bd388621a598bba01308238d joe-3.1.ebuild 1282
-MD5 d25dc59edc1c0959613a7ecb09289af9 ChangeLog 3457
+MD5 8d79089697aab86c33a0e668bfdecb9c joe-3.0-r2.ebuild 1467
+MD5 c6268a38dfcd966ca2fcfcdfd6874af5 ChangeLog 3719
MD5 aae33cfa3be544ca68973d0a8c8ff53f metadata.xml 758
-MD5 ac08ada3dfe348bc96ff85aff854e31a files/digest-joe-3.1 59
-MD5 8115b4ae2f2702a436c3008f32ae6ca4 files/digest-joe-3.0-r1 59
+MD5 fc86930505ea8eaa7f3128fc03752760 joe-3.1-r1.ebuild 1439
+MD5 94eae235e8e8f4c5152ebda30d79cd9d files/joe-3.1-overflow.patch 386
+MD5 1b4c305f8a53a6eec3f5ff94851985a4 files/joe-3.0-overflow.patch 354
+MD5 8115b4ae2f2702a436c3008f32ae6ca4 files/digest-joe-3.0-r2 59
+MD5 ac08ada3dfe348bc96ff85aff854e31a files/digest-joe-3.1-r1 59
diff --git a/app-editors/joe/files/digest-joe-3.0-r2 b/app-editors/joe/files/digest-joe-3.0-r2
new file mode 100644
index 000000000000..c93bd5dd113f
--- /dev/null
+++ b/app-editors/joe/files/digest-joe-3.0-r2
@@ -0,0 +1 @@
+MD5 05395f2f8566351d660c48390cf31dc6 joe-3.0.tar.gz 310584
diff --git a/app-editors/joe/files/digest-joe-3.1-r1 b/app-editors/joe/files/digest-joe-3.1-r1
new file mode 100644
index 000000000000..60dd3d25ba99
--- /dev/null
+++ b/app-editors/joe/files/digest-joe-3.1-r1
@@ -0,0 +1 @@
+MD5 2a6ef018870fca9b7df85401994fb0e0 joe-3.1.tar.gz 381201
diff --git a/app-editors/joe/files/joe-3.0-overflow.patch b/app-editors/joe/files/joe-3.0-overflow.patch
new file mode 100644
index 000000000000..493ef8d3d011
--- /dev/null
+++ b/app-editors/joe/files/joe-3.0-overflow.patch
@@ -0,0 +1,12 @@
+--- rc.c~ 2004-04-23 16:02:18.000000000 +0100
++++ rc.c 2004-11-16 20:41:33.000000000 +0000
+@@ -708,7 +708,8 @@
+ int line = 0; /* Line number */
+ int err = 0; /* Set to 1 if there was a syntax error */
+
+- strcpy(buf, name);
++ strncpy(buf, name, sizeof(buf) - 1);
++ buf[sizeof(buf)-1] = '\0';
+ #ifdef __MSDOS__
+ fd = fopen((char *)buf, "rt");
+ #else
diff --git a/app-editors/joe/files/joe-3.1-overflow.patch b/app-editors/joe/files/joe-3.1-overflow.patch
new file mode 100644
index 000000000000..c30822631d92
--- /dev/null
+++ b/app-editors/joe/files/joe-3.1-overflow.patch
@@ -0,0 +1,12 @@
+--- rc.c~ 2004-05-28 17:37:30.000000000 +0100
++++ rc.c 2004-11-16 20:33:47.000000000 +0000
+@@ -810,7 +810,8 @@
+ int line = 0; /* Line number */
+ int err = 0; /* Set to 1 if there was a syntax error */
+
+- strcpy((char *)buf, (char *)name);
++ strncpy((char *)buf, (char *)name, sizeof(buf) - 1);
++ buf[sizeof(buf)-1] = '\0';
+ #ifdef __MSDOS__
+ fd = fopen((char *)buf, "rt");
+ #else
diff --git a/app-editors/joe/joe-3.0-r1.ebuild b/app-editors/joe/joe-3.0-r2.ebuild
index 5d8b953ffa4b..9e44f9003dd8 100644
--- a/app-editors/joe/joe-3.0-r1.ebuild
+++ b/app-editors/joe/joe-3.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.0-r1.ebuild,v 1.13 2004/08/12 00:25:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.0-r2.ebuild,v 1.1 2004/11/22 13:32:11 tomk Exp $
inherit flag-o-matic gnuconfig
@@ -19,6 +19,8 @@ PROVIDE="virtual/editor"
src_unpack() {
unpack ${A}
cd ${S}
+ # Fix for non-critical buffer overflow, bug #71129
+ epatch ${FILESDIR}/${P}-overflow.patch || die "epatch failed"
# Fix bug #50271 (joe 3.0 documentation doesn't reflect new config file location)
sed -e 's:${prefix}/etc/joerc:@sysconfdir@/joe/joerc:' -i joerc.in
for i in jmacsrc.in jpicorc.in jstarrc.in rjoerc.in joe.1.in
@@ -37,7 +39,7 @@ src_compile() {
}
src_install() {
- einstall || die
+ make install DESTDIR=${D} || die "make install failed"
dodoc ChangeLog HINTS INFO LIST NEWS README README.cvs TODO
}
diff --git a/app-editors/joe/joe-3.1.ebuild b/app-editors/joe/joe-3.1-r1.ebuild
index 1799724a65e5..e8aaa99ecb4b 100644
--- a/app-editors/joe/joe-3.1.ebuild
+++ b/app-editors/joe/joe-3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.1.ebuild,v 1.1 2004/10/13 17:57:23 tomk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-3.1-r1.ebuild,v 1.1 2004/11/22 13:32:11 tomk Exp $
inherit flag-o-matic
@@ -19,6 +19,8 @@ PROVIDE="virtual/editor"
src_unpack() {
unpack ${A}
cd ${S}
+ # Fix for non-critical buffer overflow, bug #71129
+ epatch ${FILESDIR}/${P}-overflow.patch || die "epatch failed"
# Fix bug #50271 (joe 3.0 documentation doesn't reflect new config file location)
sed -e 's:${prefix}/etc/joerc:@sysconfdir@/joe/joerc:' -i joerc.in
for i in jmacsrc.in jpicorc.in jstarrc.in rjoerc.in joe.1.in
@@ -36,7 +38,7 @@ src_compile() {
}
src_install() {
- einstall || die
+ make install DESTDIR=${D} || die "make install failed"
dodoc ChangeLog HINTS INFO LIST NEWS README README.cvs TODO
}