summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/denyhosts/ChangeLog8
-rw-r--r--app-admin/denyhosts/Manifest14
-rw-r--r--app-admin/denyhosts/denyhosts-1.1.2-r1.ebuild63
-rw-r--r--app-admin/denyhosts/files/digest-denyhosts-1.1.2-r11
4 files changed, 74 insertions, 12 deletions
diff --git a/app-admin/denyhosts/ChangeLog b/app-admin/denyhosts/ChangeLog
index f484bdffd8d0..3119f741df4e 100644
--- a/app-admin/denyhosts/ChangeLog
+++ b/app-admin/denyhosts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/denyhosts
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.3 2005/11/05 21:13:44 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/ChangeLog,v 1.4 2005/11/11 10:23:53 strerror Exp $
+
+*denyhosts-1.1.2-r1 (11 Nov 2005)
+
+ 11 Nov 2005; Benjamin Smee <strerror@gentoo.org>
+ +denyhosts-1.1.2-r1.ebuild:
+ Sed call to fix initscript issue as per bug #110324. Added ~amd64
05 Nov 2005; Fernando J. Pereda <ferdy@gentoo.org> denyhosts-1.1.2.ebuild:
added ~alpha keyword wrt bug #110576
diff --git a/app-admin/denyhosts/Manifest b/app-admin/denyhosts/Manifest
index ba812875afbf..f1baf6052fc4 100644
--- a/app-admin/denyhosts/Manifest
+++ b/app-admin/denyhosts/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 96c066a233acc935e6f08f8af6b6d425 denyhosts-1.1.2.ebuild 1531
-MD5 8541fab801697dad6115d40c0779d522 ChangeLog 693
+MD5 15c0a126d1dc99c4c5daced6d432fd2d denyhosts-1.1.2-r1.ebuild 1637
+MD5 1cbbe10aef9e107ca44e4b718fd0fd86 ChangeLog 881
MD5 82c6f940fc1a08d481d8d46de563bce7 metadata.xml 203
+MD5 de49bade96ff5bfa9d27a281c17a3e3e files/digest-denyhosts-1.1.2-r1 66
MD5 de49bade96ff5bfa9d27a281c17a3e3e files/digest-denyhosts-1.1.2 66
MD5 90c425b8fbcfa5fc084063999c2e3b9a files/denyhosts-gentoo.patch 2395
MD5 4e9d8193a9efd5714debeec451b6b777 files/denyhosts.init 345
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDbSDAViELBEf1JB0RAvK+AJ4tc4F1/GlPeBv27lKgyGWzfXFwSQCeICLI
-b5pZxkDoCy9wjze9LkSyLOg=
-=Ym+N
------END PGP SIGNATURE-----
diff --git a/app-admin/denyhosts/denyhosts-1.1.2-r1.ebuild b/app-admin/denyhosts/denyhosts-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..e1a18e3c39c7
--- /dev/null
+++ b/app-admin/denyhosts/denyhosts-1.1.2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/denyhosts/denyhosts-1.1.2-r1.ebuild,v 1.1 2005/11/11 10:23:53 strerror Exp $
+
+inherit distutils eutils
+
+my_PN="DenyHosts"
+my_P="${my_PN}-${PV}"
+DESCRIPTION="DenyHosts is a utility to help sys admins thwart ssh hackers"
+HOMEPAGE="http://denyhosts.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${my_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~x86 ~amd64"
+IUSE=""
+DEPEND=">=dev-lang/python-2.3"
+S="${WORKDIR}/${my_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # changes default file installations
+ epatch "${FILESDIR}"/${PN}-gentoo.patch
+ sed -i -e 's:#!/usr/bin/env python:#!/usr/bin/python:' \
+ denyhosts.py || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc
+ insopts -m0640
+ newins denyhosts.cfg-dist denyhosts.conf
+
+ newinitd "${FILESDIR}"/denyhosts.init denyhosts
+
+ exeinto /usr/bin
+ newexe denyhosts.py denyhosts
+
+ dodoc CHANGELOG.txt README.txt
+
+ keepdir /var/lib/denyhosts
+}
+
+pkg_postinst() {
+ if [ ! -f /etc/hosts.deny ]
+ then
+ touch /etc/hosts.deny
+ fi
+
+ einfo "You can configure DenyHosts to run as a daemon by running:"
+ einfo
+ einfo "rc-update add denyhosts default"
+ einfo
+ einfo "or as a cronjob, by adding the following to /etc/crontab"
+ einfo "# run DenyHosts every 10 minutes"
+ einfo "*/10 * * * * root python /usr/bin/denyhosts -c /etc/denyhosts.conf"
+ einfo
+ einfo "More information can be found at http://denyhosts.sourceforge.net/faq.html"
+ einfo
+ ewarn "Modify /etc/denyhosts.conf to suit your environment system."
+}
+
diff --git a/app-admin/denyhosts/files/digest-denyhosts-1.1.2-r1 b/app-admin/denyhosts/files/digest-denyhosts-1.1.2-r1
new file mode 100644
index 000000000000..e8578af757c9
--- /dev/null
+++ b/app-admin/denyhosts/files/digest-denyhosts-1.1.2-r1
@@ -0,0 +1 @@
+MD5 d2c6f00243c0fcd0f4498c3c71a1074e DenyHosts-1.1.2.tar.gz 31000