summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/semantic/semantic-1.4.4-r2.ebuild')
-rw-r--r--app-emacs/semantic/semantic-1.4.4-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/semantic/semantic-1.4.4-r2.ebuild b/app-emacs/semantic/semantic-1.4.4-r2.ebuild
new file mode 100644
index 000000000000..6fcacdd835cb
--- /dev/null
+++ b/app-emacs/semantic/semantic-1.4.4-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/semantic/semantic-1.4.4-r2.ebuild,v 1.1 2007/04/17 21:37:14 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="The Semantic Bovinator is a lexer, parser-generator, and parser written in Emacs Lisp"
+HOMEPAGE="http://cedet.sourceforge.net/semantic.shtml"
+SRC_URI="mirror://sourceforge/cedet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/emacs
+ >=app-emacs/speedbar-0.14_beta4
+ >=app-emacs/eieio-0.17
+ !app-emacs/cedet"
+
+SITEFILE=61${PN}-gentoo.el
+
+src_compile() {
+ make LOADPATH="${SITELISP}/speedbar ${SITELISP}/eieio" || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc *.bnf
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog NEWS INSTALL
+ doinfo semantic.info*
+}