summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/orsa/ChangeLog7
-rw-r--r--app-sci/orsa/Manifest6
-rw-r--r--app-sci/orsa/files/digest-orsa-0.3.11
-rw-r--r--app-sci/orsa/orsa-0.3.0_rc3.ebuild4
-rw-r--r--app-sci/orsa/orsa-0.3.1.ebuild33
5 files changed, 46 insertions, 5 deletions
diff --git a/app-sci/orsa/ChangeLog b/app-sci/orsa/ChangeLog
index 1b601e85e37f..37bc96194b69 100644
--- a/app-sci/orsa/ChangeLog
+++ b/app-sci/orsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/orsa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.3 2003/07/24 21:32:19 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.4 2003/10/01 06:25:37 george Exp $
+
+*orsa-0.3.1 (30 Sep 2003)
+
+ 30 Sep 2003; George Shapovalov <george@gentoo.org> orsa-0.3.1.ebuild :
+ new version
24 Jul 2003; George Shapovalov <george@gentoo.org> orsa-0.3.0_rc3.ebuild, orsa-0.3.0_rc3.ebuild :
name of the source tarballs changed on sourceforge, adjusted URI's and S= accordingly
diff --git a/app-sci/orsa/Manifest b/app-sci/orsa/Manifest
index 9f5287f2e91e..5e2aa910c093 100644
--- a/app-sci/orsa/Manifest
+++ b/app-sci/orsa/Manifest
@@ -1,6 +1,8 @@
-MD5 cfeb75fe61a093d8724a0ad3332cd767 ChangeLog 1055
MD5 df081c05a631076ac52fb9f71f44553d orsa-0.3.0_rc1.ebuild 967
+MD5 11906580c433eae53ac5b6ed63ed6ef6 orsa-0.3.0_rc3.ebuild 797
+MD5 9a4ed615310a17e0b114193c567a972a orsa-0.3.1.ebuild 751
+MD5 62cfbddc10cdae64529cccc71a9a3f7a ChangeLog 1170
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 dc58b7cd2a596c086b0576d825f59130 orsa-0.3.0_rc3.ebuild 800
MD5 4ac11cc803cd2a23ab9da8490d841e7c files/digest-orsa-0.3.0_rc1 66
MD5 9a419b528b36565c111576fcc7dfaa7c files/digest-orsa-0.3.0_rc3 66
+MD5 38ab5f417512fb8637bffdfb874be99c files/digest-orsa-0.3.1 62
diff --git a/app-sci/orsa/files/digest-orsa-0.3.1 b/app-sci/orsa/files/digest-orsa-0.3.1
new file mode 100644
index 000000000000..df838e0331f7
--- /dev/null
+++ b/app-sci/orsa/files/digest-orsa-0.3.1
@@ -0,0 +1 @@
+MD5 0c68e475aaef49f8027d787f5b6d485b orsa-0.3.1.tar.gz 541742
diff --git a/app-sci/orsa/orsa-0.3.0_rc3.ebuild b/app-sci/orsa/orsa-0.3.0_rc3.ebuild
index e5e8d53c4cbf..23e770575593 100644
--- a/app-sci/orsa/orsa-0.3.0_rc3.ebuild
+++ b/app-sci/orsa/orsa-0.3.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/orsa-0.3.0_rc3.ebuild,v 1.4 2003/09/08 07:26:06 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/orsa-0.3.0_rc3.ebuild,v 1.5 2003/10/01 06:25:37 george Exp $
inherit base flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/orsa/${PN}-${PV/_/-}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
DEPEND="virtual/glibc
dev-libs/fftw
diff --git a/app-sci/orsa/orsa-0.3.1.ebuild b/app-sci/orsa/orsa-0.3.1.ebuild
new file mode 100644
index 000000000000..14a0446eef4d
--- /dev/null
+++ b/app-sci/orsa/orsa-0.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/orsa-0.3.1.ebuild,v 1.1 2003/10/01 06:25:37 george Exp $
+
+inherit base flag-o-matic
+
+DESCRIPTION="Orbital Reconstruction, Simulation and Analysis"
+HOMEPAGE="http://orsa.sourceforge.net/"
+SRC_URI="mirror://sourceforge/orsa/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ dev-libs/fftw
+ dev-libs/gsl
+ x11-libs/qt
+ sys-libs/readline"
+
+replace-flags k6-3 i586
+replace-flags k6-2 i586
+replace-flags k6 i586
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
+}