summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild')
-rw-r--r--dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild48
1 files changed, 36 insertions, 12 deletions
diff --git a/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild b/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild
index f0e435aa6331..3fbc8609c94e 100644
--- a/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild
+++ b/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild,v 1.1 2006/12/10 00:34:04 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/mysql-community-5.1.14_beta.ebuild,v 1.2 2007/01/03 15:23:32 vivo Exp $
# Leave this empty
MYSQL_VERSION_ID=""
-MYSQL_RERELEASE=""
-# Set the patchset revision to use, must be either empty or a decimal number
-MYSQL_PATCHSET_REV=""
-BASE_URI="mirror://mysql/Downloads/MySQL-${PV%.*}"
+SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz"
+PBXT_VERSION="0.9.73-beta"
inherit mysql
@@ -15,18 +13,44 @@ inherit mysql
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
src_test() {
- cd "${S}"
- einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+
make check || die "make check failed"
if ! useq "minimal" ; then
+ cd "${S}/mysql-test"
einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
local retstatus
+ local t
+ local testopts="--force"
+
+ # sandbox make ndbd zombie
+ hasq "sandbox" ${FEATURES} && testopts="${testopts} --skip-ndb"
+
addpredict /this-dir-does-not-exist/t9.MYI
- cd mysql-test
- sed -i -e "s|PORT=3306|PORT=3307|g" mysql-test-run
- ./mysql-test-run
- retstatus=$?
+ # mysqladmin start before dir creation
+ mkdir ${S}/mysql-test/var{,/log}
+
+ if [[ ${UID} -eq 0 ]] ; then
+ mysql_disable_test "im_cmd_line" "fail as root"
+ mysql_disable_test "im_daemon_life_cycle" "fail as root"
+ mysql_disable_test "im_instance_conf" "fail as root"
+ mysql_disable_test "im_life_cycle" "fail as root"
+ mysql_disable_test "im_options" "fail as root"
+ mysql_disable_test "im_utils" "fail as root"
+ mysql_disable_test "trigger" "fail as root"
+ fi
+
+ useq "extraengine" && mysql_disable_test "federated" "fail with extraengine"
+
+ mysql_disable_test "view" "FIXME: fail because now we are in year 2007"
+
+ # from Makefile.am:
+ retstatus=1
+ ./mysql-test-run.pl ${testopts} --mysqld=--binlog-format=mixed \
+ && ./mysql-test-run.pl ${testopts} --ps-protocol --mysqld=--binlog-format=row \
+ && ./mysql-test-run.pl ${testopts} --ps-protocol --mysqld=--binlog-format=mixed \
+ && ./mysql-test-run.pl ${testopts} --mysqld=--binlog-format=row \
+ && retstatus=0
# Just to be sure ;)
pkill -9 -f "${S}/ndb" 2>/dev/null