summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libsecp256k1/libsecp256k1-9999.ebuild')
-rw-r--r--dev-libs/libsecp256k1/libsecp256k1-9999.ebuild24
1 files changed, 17 insertions, 7 deletions
diff --git a/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild b/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
index b98b2807b583..aee29f252e78 100644
--- a/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
+++ b/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild,v 1.1 2014/11/21 11:42:50 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild,v 1.2 2015/03/04 12:39:27 blueness Exp $
EAPI=5
EGIT_REPO_URI="https://github.com/bitcoin/secp256k1.git"
-inherit git-2 autotools
+inherit git-2 autotools eutils
DESCRIPTION="Optimized C library for EC operations on curve secp256k1"
HOMEPAGE="https://github.com/bitcoin/secp256k1"
@@ -13,18 +13,17 @@ HOMEPAGE="https://github.com/bitcoin/secp256k1"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="asm doc endomorphism test"
+IUSE="asm doc endomorphism gmp test"
REQUIRED_USE="
asm? ( amd64 )
"
RDEPEND="
- dev-libs/gmp
+ gmp? ( dev-libs/gmp )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
>=sys-devel/gcc-4.7
- asm? ( dev-lang/yasm )
test? ( dev-libs/openssl )
"
@@ -33,11 +32,22 @@ src_prepare() {
}
src_configure() {
+ local field
+ if use gmp && ! use asm; then
+ field=gmp
+ elif use amd64; then
+ field=64bit
+ else
+ field=32bit
+ fi
+
econf \
--disable-benchmark \
$(use_enable test tests) \
$(use_enable endomorphism) \
- --with-field=$(usex asm 64bit_asm $(usex amd64 64bit gmp)) \
+ --with-asm=$(usex asm auto no) \
+ --with-bignum=$(usex gmp gmp no) \
+ --with-field=${field} \
--disable-static
}