summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-lml/cl-lml-2.5.2.ebuild')
-rw-r--r--dev-lisp/cl-lml/cl-lml-2.5.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lisp/cl-lml/cl-lml-2.5.2.ebuild b/dev-lisp/cl-lml/cl-lml-2.5.2.ebuild
new file mode 100644
index 000000000000..321a63ca7f56
--- /dev/null
+++ b/dev-lisp/cl-lml/cl-lml-2.5.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lml/cl-lml-2.5.2.ebuild,v 1.1 2003/10/17 17:17:02 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp package to provide a markup language for generation XHTML web pages"
+HOMEPAGE="http://lml.b9.com/
+ http://www.cliki.net/LML"
+SRC_URI="ftp://lml.med-info.com/lml-${PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=lml
+
+S=${WORKDIR}/lml-${PV}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dohtml doc/readme.html
+ docinto examples
+ dodoc doc/readme.lml
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}