summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-tbnl')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest10
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.8.6.ebuild39
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.61
4 files changed, 52 insertions, 5 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index 009c25c9b0b3..3faac741d953 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.19 2005/11/15 02:26:26 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.20 2005/11/21 06:23:28 mkennedy Exp $
+
+*cl-tbnl-0.8.6 (21 Nov 2005)
+
+ 21 Nov 2005; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.8.6.ebuild:
+ New upstream version.
*cl-tbnl-0.8.5 (15 Nov 2005)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index 49edbbcdeb60..f852abfbad12 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -1,14 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 c048af2b15e0b64be56d34fe6a66b376 ChangeLog 3439
+MD5 c1645ceaba33d06c1afb934bd0dce8af ChangeLog 3570
MD5 2210668b120e68270c084144b1725a92 cl-tbnl-0.8.5.ebuild 1012
+MD5 9244619f98a4dc87ffc73f088813bd5e cl-tbnl-0.8.6.ebuild 1012
MD5 5a4e62c91dc1bfcb263c02699a60e525 files/digest-cl-tbnl-0.8.5 66
+MD5 03889525092b2949aa508ed396f67f6b files/digest-cl-tbnl-0.8.6 66
MD5 a2199253dbe57d398c785af8f7744485 metadata.xml 804
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDeUdeyiNZaEAZA+ARAjpIAJ4yBYToS/KOWMOAcmiFK+KncCRxJACeIbkO
-AJZ1/Yg+j9Tq3v18kLg74/8=
-=KCgZ
+iD4DBQFDgWgyyiNZaEAZA+ARAofpAJ4/0R12+EOUCNbvAQTIDDl/h8Ev4wCYoN5a
+o8kiqUiJVeMNcsywgEuaXg==
+=5ugl
-----END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.8.6.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.8.6.ebuild
new file mode 100644
index 000000000000..3ef60ea95dd8
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.8.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.8.6.ebuild,v 1.1 2005/11/21 06:23:28 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="standalone"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-rfc2388"
+
+# RDEPEND="${DEPEND}
+# apache2? ( www-apache/mod_lisp2 ) !apache2? ( www-apache/mod_lisp )"
+
+RDEPEND="${DEPEND}
+ !standalone? ( www-apache/mod_lisp )"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/
+ doins -r test contrib
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.6 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.6
new file mode 100644
index 000000000000..3847573c80fd
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.8.6
@@ -0,0 +1 @@
+MD5 b40743385f1d5cfb9168bfc95f30b679 tbnl_0.8.6.orig.tar.gz 86764