summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/qmamecat/qmamecat-0.44.45.ebuild')
-rw-r--r--games-emulation/qmamecat/qmamecat-0.44.45.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-emulation/qmamecat/qmamecat-0.44.45.ebuild b/games-emulation/qmamecat/qmamecat-0.44.45.ebuild
new file mode 100644
index 000000000000..42d957bdcb78
--- /dev/null
+++ b/games-emulation/qmamecat/qmamecat-0.44.45.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/qmamecat/qmamecat-0.44.45.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+MY_PV="${PV/45/b45}"
+DESCRIPTION="QT mame catalog and frontend"
+HOMEPAGE="http://www.mameworld.net/mamecat/"
+SRC_URI="http://www.mameworld.net/mamecat/snapshots/qmamecat-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ x11-libs/qt"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ # emake is horribly broken
+ make COPTIM="${CFLAGS}" || die
+}
+
+src_install() {
+ rm bin/{Makefile,make.cfg}
+ dobin bin/*
+ doman doc/*.6
+ rm doc/*.6
+ dodoc doc/*
+}