summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/ChangeLog7
-rw-r--r--kde-base/cantor/cantor-4.4.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index d654422aba32..aa84cc3d1ef7 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.6 2010/03/31 21:59:55 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.7 2010/05/03 20:14:31 alexxy Exp $
+
+*cantor-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> +cantor-4.4.3.ebuild:
+ Version bump
31 Mar 2010; Dror Levin <spatz@gentoo.org> -cantor-4.4.0.ebuild:
Remove old KDE versions.
diff --git a/kde-base/cantor/cantor-4.4.3.ebuild b/kde-base/cantor/cantor-4.4.3.ebuild
new file mode 100644
index 000000000000..33f9a3e6894a
--- /dev/null
+++ b/kde-base/cantor/cantor-4.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.4.3.ebuild,v 1.1 2010/05/03 20:14:31 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook ps +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ ps? ( app-text/libspectre )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+src_configure() {
+ mycmakeargs+="
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with R)
+ "
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}