summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog8
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.7.0.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 9f0bcec049fe..6cd5f0378de2 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.22 2011/07/09 15:14:11 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.23 2011/07/27 14:04:33 alexxy Exp $
+
+*dolphin-plugins-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +dolphin-plugins-4.7.0.ebuild:
+ Version bump KDE SC 4.7.0
*dolphin-plugins-4.6.5 (09 Jul 2011)
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.7.0.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.7.0.ebuild
new file mode 100644
index 000000000000..229b2bbb3f3a
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.7.0.ebuild,v 1.1 2011/07/27 14:04:33 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +git +subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ git? ( dev-vcs/git )
+ subversion? ( dev-vcs/subversion )
+"
+
+# SCM plugins moved from dolphin somewhere before 4.4.75
+add_blocker dolphin '<4.4.75'
+
+KMLOADLIBS="libkonq"
+
+#
+# See bug 351147 for why this is necessary
+#
+src_prepare() {
+ echo 'macro_optional_add_subdirectory ( dolphin-plugins )' >> CMakeLists.txt || die
+ echo > dolphin-plugins/CMakeLists.txt || die
+ use git && echo 'add_subdirectory ( git )' >> dolphin-plugins/CMakeLists.txt
+ use subversion && echo 'add_subdirectory ( svn )' >> dolphin-plugins/CMakeLists.txt
+
+ kde4-meta_src_prepare
+}
+
+src_install() {
+ { use git || use subversion; } && kde4-meta_src_install
+}