summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kajongg/kajongg-4.9.3.ebuild')
-rw-r--r--kde-base/kajongg/kajongg-4.9.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/kde-base/kajongg/kajongg-4.9.3.ebuild b/kde-base/kajongg/kajongg-4.9.3.ebuild
new file mode 100644
index 000000000000..da41c9d02535
--- /dev/null
+++ b/kde-base/kajongg/kajongg-4.9.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kajongg/kajongg-4.9.3.ebuild,v 1.1 2012/11/08 23:27:10 creffett Exp $
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]]; then
+ eclass="kde4-base"
+else
+ eclass="kde4-meta"
+ KMNAME="kdegames"
+fi
+KDE_HANDBOOK="optional"
+PYTHON_DEPEND="2:2.6"
+inherit ${eclass} python
+
+DESCRIPTION="The classical Mah Jongg for four players"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ dev-db/sqlite:3
+ $(add_kdebase_dep libkdegames)
+ $(add_kdebase_dep pykde4)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep libkmahjongg)
+ >=dev-python/twisted-8.2.0
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ ${eclass}_pkg_setup
+}
+
+src_prepare() {
+ if [[ ${PV} == *9999 ]]; then
+ python_convert_shebangs -r 2 src
+ else
+ python_convert_shebangs -r 2 kajongg/src
+ fi
+ ${eclass}_src_prepare
+}