summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/noatun-plugins')
-rw-r--r--kde-base/noatun-plugins/ChangeLog9
-rw-r--r--kde-base/noatun-plugins/Manifest10
-rw-r--r--kde-base/noatun-plugins/files/configure-fix-kdeaddons-db.patch50
-rw-r--r--kde-base/noatun-plugins/files/configure-fix-kdeaddons-sdl.patch33
-rw-r--r--kde-base/noatun-plugins/files/digest-noatun-plugins-3.4.21
-rw-r--r--kde-base/noatun-plugins/noatun-plugins-3.4.2.ebuild20
6 files changed, 119 insertions, 4 deletions
diff --git a/kde-base/noatun-plugins/ChangeLog b/kde-base/noatun-plugins/ChangeLog
index 1dd4f5e2a7da..643d256c1b0f 100644
--- a/kde-base/noatun-plugins/ChangeLog
+++ b/kde-base/noatun-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/noatun-plugins
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.10 2005/07/08 05:04:08 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.11 2005/07/28 21:16:26 danarmak Exp $
+
+*noatun-plugins-3.4.2 (28 Jul 2005)
+
+ 28 Jul 2005; Dan Armak <danarmak@gentoo.org>
+ +files/configure-fix-kdeaddons-db.patch,
+ +files/configure-fix-kdeaddons-sdl.patch, +noatun-plugins-3.4.2.ebuild:
+ Version bump to 3.4.2.
08 Jul 2005; Jason Wever <weeve@gentoo.org> noatun-plugins-3.4.1.ebuild:
Stable on SPARC.
diff --git a/kde-base/noatun-plugins/Manifest b/kde-base/noatun-plugins/Manifest
index b84b2b6d3f36..0e3344639bdc 100644
--- a/kde-base/noatun-plugins/Manifest
+++ b/kde-base/noatun-plugins/Manifest
@@ -1,7 +1,11 @@
-MD5 ba7c421c71102cf3807bce1c3112c6c4 ChangeLog 1566
-MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
MD5 16088a67d1d91630272ae27cc03c5d4f noatun-plugins-3.4.0.ebuild 868
+MD5 17825e6e62c44d1ce9c7f2a4cd795dd0 noatun-plugins-3.4.2.ebuild 772
MD5 29c3d2be2f371b987d1730480efabc4b noatun-plugins-3.4.1.ebuild 866
+MD5 6fd6ba3afe57a9269c68492dcaebaa57 ChangeLog 1793
+MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
+MD5 440dc255b1315302c2dfbf0f1233f3bf files/configure-fix-kdeaddons-db.patch 1612
+MD5 6ec5a8a3f0f5ae85d431525c926c27fe files/noatun-oblique-db-location-3.4.0_rc1.diff 625
+MD5 8ad71a2139b4a330c5adfb4247b84c8c files/configure-fix-kdeaddons-sdl.patch 867
MD5 231586b7509d98416a3043180cebfe60 files/digest-noatun-plugins-3.4.0 69
MD5 60c005ebe876a0e127dcf1083620803e files/digest-noatun-plugins-3.4.1 215
-MD5 6ec5a8a3f0f5ae85d431525c926c27fe files/noatun-oblique-db-location-3.4.0_rc1.diff 625
+MD5 bed9e2e46d8e7de37c5996e1ad3025bd files/digest-noatun-plugins-3.4.2 69
diff --git a/kde-base/noatun-plugins/files/configure-fix-kdeaddons-db.patch b/kde-base/noatun-plugins/files/configure-fix-kdeaddons-db.patch
new file mode 100644
index 000000000000..19d467ecef80
--- /dev/null
+++ b/kde-base/noatun-plugins/files/configure-fix-kdeaddons-db.patch
@@ -0,0 +1,50 @@
+Index: noatun-plugins/oblique/configure.in.in
+===================================================================
+--- noatun-plugins/oblique/configure.in.in (revision 433553)
++++ noatun-plugins/oblique/configure.in.in (working copy)
+@@ -1,19 +1,31 @@
++AC_ARG_WITH(berkeley-db,
++ [AS_HELP_STRING(--with-berkeley-db,
++ [enable support for Berkeley DB++ @<:@default=check@:>@])],
++ [], with_berkeley_db=check)
+
+-AC_MSG_CHECKING(for Berkeley DB++)
++AC_ARG_WITH(db-lib,
++ [AS_HELP_STRING([--with-db-lib=NAME],[name of the Berkeley DB++ library @<:@default=db_cxx@:>@])],
++ [ac_db_name="$withval"], [ac_db_name="db_cxx"])
++
+ berkeley_db=no
+-AC_LANG_PUSH(C++)
+-AC_TRY_COMPILE([
+- #include <db_cxx.h>
+- ],[
+- ],[
+- berkeley_db=yes
+- ])
+-AC_MSG_RESULT($berkeley_db)
+-AC_DEFINE(BERKELEY_DB,1,[Define if you have Berkeley DB++ installed])
+-BERKELEY_DB_LIBS="-ldb_cxx"
+-AC_SUBST(BERKELEY_DB_LIBS)
+-AC_LANG_POP(C++)
++if test "x$with_berkeley_db" != xno; then
++ berkeley_db=yes
+
+-AM_CONDITIONAL(include_BERKELEY_DB, test "$berkeley_db" = yes)
++ KDE_CHECK_HEADER([db_cxx.h],
++ [:], [berkeley_db=no])
+
++ AC_CHECK_LIB([$ac_db_name], [main],
++ [:], [berkeley_db=no])
+
++ if test "x$berkeley_db" = xyes; then
++ AC_DEFINE(BERKELEY_DB, 1, [Define if you have Berkeley DB++ installed])
++ BERKELEY_DB_LIBS="-l$ac_db_name"
++ AC_SUBST(BERKELEY_DB_LIBS)
++ fi
++
++ if test "x$with_berkeley_db" != xcheck && test "x$berkeley_db" != xyes; then
++ AC_MSG_FAILURE([--with-berkeley-db was given, but test for Berkeley DB++ failed])
++ fi
++fi
++
++AM_CONDITIONAL(include_BERKELEY_DB, test "$berkeley_db" = yes)
diff --git a/kde-base/noatun-plugins/files/configure-fix-kdeaddons-sdl.patch b/kde-base/noatun-plugins/files/configure-fix-kdeaddons-sdl.patch
new file mode 100644
index 000000000000..044f7c2d7618
--- /dev/null
+++ b/kde-base/noatun-plugins/files/configure-fix-kdeaddons-sdl.patch
@@ -0,0 +1,33 @@
+Index: noatun-plugins/configure.in.in
+===================================================================
+--- noatun-plugins/configure.in.in (revision 428268)
++++ noatun-plugins/configure.in.in (working copy)
+@@ -173,14 +173,20 @@
+ noatun_sdl=no
+ dnl Check for SDL
+ dnl require SDL 1.2 just because it's the new stable version, and it's what I have
+-NOATUN_PATH_SDL(
+-[1.2.0],
+-[
+-noatun_sdl=yes
+-],
+-[
+-]
+-)
++
++AC_ARG_WITH(sdl,
++ [AS_HELP_STRING(--with-sdl,
++ [enable SDL Noatun plugins @<:@default=check@:>@])],
++ [], with_sdl=check)
++
++if test "x$with_sdl" != xno; then
++ NOATUN_PATH_SDL([1.2.0], [noatun_sdl=yes], [])
++
++ if test "x$with_sdl" != xcheck && test "x$noatun_sdl" != xyes; then
++ AC_MSG_FAILURE([--with-sdl was given, but test for SDL failed])
++ fi
++fi
++
+ AM_CONDITIONAL(include_SDL, test "$noatun_sdl" = yes)
+
+ AC_CHECK_HEADERS(endian.h)
diff --git a/kde-base/noatun-plugins/files/digest-noatun-plugins-3.4.2 b/kde-base/noatun-plugins/files/digest-noatun-plugins-3.4.2
new file mode 100644
index 000000000000..554aacd0d674
--- /dev/null
+++ b/kde-base/noatun-plugins/files/digest-noatun-plugins-3.4.2
@@ -0,0 +1 @@
+MD5 af4fc7fa0dde8894b9d9582ecef7df2a kdeaddons-3.4.2.tar.bz2 1591335
diff --git a/kde-base/noatun-plugins/noatun-plugins-3.4.2.ebuild b/kde-base/noatun-plugins/noatun-plugins-3.4.2.ebuild
new file mode 100644
index 000000000000..3965b64a85b7
--- /dev/null
+++ b/kde-base/noatun-plugins/noatun-plugins-3.4.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.4.2.ebuild,v 1.1 2005/07/28 21:16:26 danarmak Exp $
+KMNAME=kdeaddons
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="Various plugins for noatun"
+KEYWORDS=" ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="arts sdl berkdb"
+DEPEND="$(deprange-dual $PV $MAXKDEVER kde-base/noatun)
+ arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+ sdl? ( >=media-libs/libsdl-1.2 )
+ berkdb? ( =sys-libs/db-4.2* )"
+
+PATCHES="$FILESDIR/configure-fix-kdeaddons-db.patch
+ $FILESDIR/configure-fix-kdeaddons-sdl.patch"
+myconf="$(use_with berkdb berkeley-db) $(use_with sdl) --with-db-lib=db_cxx-4.2"
+