summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdebindings-ruby/ChangeLog10
-rw-r--r--kde-base/kdebindings-ruby/files/kdebindings-ruby-fix-linkage.patch34
-rw-r--r--kde-base/kdebindings-ruby/kdebindings-ruby-4.4.0.ebuild94
3 files changed, 138 insertions, 0 deletions
diff --git a/kde-base/kdebindings-ruby/ChangeLog b/kde-base/kdebindings-ruby/ChangeLog
new file mode 100644
index 000000000000..174d7f50a2a3
--- /dev/null
+++ b/kde-base/kdebindings-ruby/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for kde-base/kdebindings-ruby
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.1 2010/02/09 00:21:37 alexxy Exp $
+
+*kdebindings-ruby-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdebindings-ruby-4.4.0.ebuild, +files/kdebindings-ruby-fix-linkage.patch:
+ Version bump to KDE SC 4.4.0
+
diff --git a/kde-base/kdebindings-ruby/files/kdebindings-ruby-fix-linkage.patch b/kde-base/kdebindings-ruby/files/kdebindings-ruby-fix-linkage.patch
new file mode 100644
index 000000000000..3e087ff1603f
--- /dev/null
+++ b/kde-base/kdebindings-ruby/files/kdebindings-ruby-fix-linkage.patch
@@ -0,0 +1,34 @@
+Unfortunately, it seems upstream hasn't added all the needed libraries for linking... fix that
+
+--- kdebindings/ruby/qtscript/CMakeLists.txt
++++ kdebindings/ruby/qtscript/CMakeLists.txt
+@@ -4,7 +4,7 @@
+ set(qtscript_LIBRARY_SRC qtscript.cpp qtscripthandlers.cpp)
+
+ add_library(qtscript MODULE ${qtscript_LIBRARY_SRC})
+-target_link_libraries(qtscript ${QT_QTCORE_LIBRARY} ${RUBY_LIBRARY} smokeqtcore smokeqtscript qtruby4shared)
++target_link_libraries(qtscript ${QT_QTCORE_LIBRARY} ${QT_QTSCRIPT_LIBRARY} ${RUBY_LIBRARY} smokeqtcore smokeqtscript qtruby4shared)
+ set_target_properties(qtscript PROPERTIES PREFIX "")
+ install(TARGETS qtscript DESTINATION ${CUSTOM_RUBY_SITE_ARCH_DIR})
+ install(FILES qtscript.rb DESTINATION ${CUSTOM_RUBY_SITE_LIB_DIR}/qtscript)
+--- kdebindings/ruby/soprano/CMakeLists.txt
++++ kdebindings/ruby/soprano/CMakeLists.txt
+@@ -3,7 +3,7 @@
+
+ set(rubysoprano_LIBRARY_SRC soprano.cpp sopranohandlers.cpp)
+ add_library(rubysoprano MODULE ${rubysoprano_LIBRARY_SRC})
+-target_link_libraries(rubysoprano ${QT_QTCORE_LIBRARY} ${RUBY_LIBRARY} smokeqtcore smokesoprano qtruby4shared)
++target_link_libraries(rubysoprano ${QT_QTCORE_LIBRARY} ${RUBY_LIBRARY} ${SOPRANO_LIBRARIES} smokeqtcore smokesoprano qtruby4shared)
+ set_target_properties(rubysoprano PROPERTIES PREFIX "" OUTPUT_NAME soprano)
+ install(TARGETS rubysoprano DESTINATION ${CUSTOM_RUBY_SITE_ARCH_DIR})
+ install(FILES soprano.rb DESTINATION ${CUSTOM_RUBY_SITE_LIB_DIR}/soprano)
+--- kdebindings/ruby/nepomuk/CMakeLists.txt
++++ kdebindings/ruby/nepomuk/CMakeLists.txt
+@@ -7,6 +7,7 @@
+ target_link_libraries(rubynepomuk
+ ${RUBY_LIBRARY}
+ ${NEPOMUK_LIBRARIES}
++ ${SOPRANO_LIBRARIES}
+ smokeqtcore
+ smokesoprano
+ smokekdecore
diff --git a/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.0.ebuild b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.0.ebuild
new file mode 100644
index 000000000000..250c9b076139
--- /dev/null
+++ b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.0.ebuild,v 1.1 2010/02/09 00:21:37 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+KMMODULE="ruby"
+WEBKIT_REQUIRED="optional"
+
+USE_RUBY="ruby18"
+
+inherit kde4-meta ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="akonadi debug kdevplatform phonon plasma qscintilla qwt semantic-desktop"
+
+DEPEND="
+ $(add_kdebase_dep smoke 'akonadi?,kdevplatform?,phonon?,qscintilla?,qwt?,semantic-desktop?')
+"
+
+RDEPEND="${DEPEND}
+ !dev-ruby/qt4-qtruby
+"
+
+KMEXTRACTONLY="
+ ruby/krossruby
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-linkage.patch
+)
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_unpack() {
+ kde4-meta_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-meta_src_prepare
+
+ sed -i -e "s#smoke/smoke.h#smoke.h#" \
+ ruby/qtruby/src/handlers.cpp \
+ ruby/qtruby/src/marshall.h \
+ ruby/qtruby/src/marshall_types.h \
+ ruby/qtruby/src/Qt.cpp \
+ ruby/qtruby/src/qtruby.cpp \
+ ruby/qtruby/src/qtruby.h \
+ ruby/qtruby/src/smokeruby.h || die
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ $(cmake-utils_use_enable akonadi KdepimLibs)
+ $(cmake-utils_use_enable akonadi)
+ $(cmake-utils_use_enable kdevplatform KDEVPLATFORM_RUBY)
+ $(cmake-utils_use_with kdevplatform KDevPlatform)
+ $(cmake-utils_use_enable plasma PLASMA_RUBY)
+ $(cmake-utils_use_enable phonon)
+ $(cmake-utils_use_enable phonon PHONON_RUBY)
+ $(cmake-utils_use_enable qscintilla QScintilla)
+ $(cmake-utils_use_enable qscintilla QSCINTILLA_RUBY)
+ $(cmake-utils_use_enable qwt QWT_RUBY)
+ $(cmake-utils_use_enable semantic-desktop Soprano)
+ $(cmake-utils_use_enable semantic-desktop SOPRANO_RUBY)
+ $(cmake-utils_use_enable semantic-desktop Nepomuk)
+ $(cmake-utils_use_enable webkit QTWEBKIT_RUBY)
+ -DENABLE_KROSSRUBY=OFF
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ )
+ kde4-meta_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_install
+}