summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/cantata/cantata-0.8.1.ebuild')
-rw-r--r--media-sound/cantata/cantata-0.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/cantata/cantata-0.8.1.ebuild b/media-sound/cantata/cantata-0.8.1.ebuild
new file mode 100644
index 000000000000..67b147d7df55
--- /dev/null
+++ b/media-sound/cantata/cantata-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cantata/cantata-0.8.1.ebuild,v 1.1 2012/07/26 22:10:34 johu Exp $
+
+EAPI=4
+
+KDE_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Cantata is a client for the music player daemon (MPD)"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=147733"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde"
+
+DEPEND="
+ media-libs/speex
+ media-libs/taglib
+ media-libs/taglib-extras
+ media-sound/mpg123
+ virtual/ffmpeg
+"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_want kde KDE_SUPPORT)
+ )
+
+ kde4-base_src_configure
+}