summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/Manifest6
-rw-r--r--media-video/mplayer/mplayer-0.91.ebuild6
-rw-r--r--media-video/mplayer/mplayer-1.0_pre1.ebuild6
3 files changed, 13 insertions, 5 deletions
diff --git a/media-video/mplayer/Manifest b/media-video/mplayer/Manifest
index 827ebbdcd62e..6338feda20a1 100644
--- a/media-video/mplayer/Manifest
+++ b/media-video/mplayer/Manifest
@@ -1,6 +1,6 @@
-MD5 713a2c7cfd69db4de8e859c236533834 ChangeLog 14249
-MD5 4810042c6180b22f35ecaeec07a3ba7f mplayer-1.0_pre1.ebuild 11182
-MD5 b356386be51e1179740ad1f8aa2522b9 mplayer-0.91.ebuild 11271
+MD5 a92242704f3282f08f73f5c7963e0e24 ChangeLog 14248
+MD5 ac8b056a5eabd91441a2724c28938266 mplayer-1.0_pre1.ebuild 11181
+MD5 87d81c330d408e2c163fa54c065ecaaa mplayer-0.91.ebuild 11270
MD5 6c2dab3392aab51766253b416ad2a10c files/default-skin.diff 396
MD5 3a99e8f86899fc5356ae8d563af2ac9c files/digest-mplayer-1.0_pre1 358
MD5 611354a9a8c185e9ae1cda37d197c073 files/digest-mplayer-0.91 355
diff --git a/media-video/mplayer/mplayer-0.91.ebuild b/media-video/mplayer/mplayer-0.91.ebuild
index 3f336f4c00ae..ca9a2efa3da2 100644
--- a/media-video/mplayer/mplayer-0.91.ebuild
+++ b/media-video/mplayer/mplayer-0.91.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-0.91.ebuild,v 1.4 2003/09/05 14:25:22 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-0.91.ebuild,v 1.5 2003/09/06 18:23:55 pappy Exp $
IUSE="dga oss xmms jpeg 3dfx sse matrox sdl X svga ggi oggvorbis 3dnow aalib gnome xv opengl truetype dvd gtk gif esd fbcon encode alsa directfb arts dvb gtk2 samba"
@@ -265,6 +265,10 @@ src_compile() {
myconf="${myconf} --enable-linux-devfs"
fi
+ if has_version 'sys-devel/hardened-gcc' && [ ${CC}="gcc" ] ; then
+ CC="${CC} -yet_exec"
+ fi
+
# Crashes on start when compiled with most optimizations.
# The code have CPU detection code now, with CPU specific
# optimizations, so extra should not be needed and is not
diff --git a/media-video/mplayer/mplayer-1.0_pre1.ebuild b/media-video/mplayer/mplayer-1.0_pre1.ebuild
index 343a2b0e842e..ff1bda755d02 100644
--- a/media-video/mplayer/mplayer-1.0_pre1.ebuild
+++ b/media-video/mplayer/mplayer-1.0_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre1.ebuild,v 1.4 2003/09/05 14:25:22 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre1.ebuild,v 1.5 2003/09/06 18:23:55 pappy Exp $
IUSE="dga oss xmms jpeg 3dfx sse matrox sdl X svga ggi oggvorbis 3dnow aalib gnome xv opengl truetype dvd gtk gif esd fbcon encode alsa directfb arts dvb gtk2 samba"
@@ -256,6 +256,10 @@ src_compile() {
myconf="${myconf} --enable-linux-devfs"
fi
+ if has_version 'sys-devel/hardened-gcc' && [ ${CC}="gcc" ] ; then
+ CC="${CC} -yet_exec"
+ fi
+
# Crashes on start when compiled with most optimizations.
# The code have CPU detection code now, with CPU specific
# optimizations, so extra should not be needed and is not