summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/cnet/cnet-2.0.5.ebuild')
-rw-r--r--net-analyzer/cnet/cnet-2.0.5.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/net-analyzer/cnet/cnet-2.0.5.ebuild b/net-analyzer/cnet/cnet-2.0.5.ebuild
index 6f8d43c29d65..ebd25aba7c92 100644
--- a/net-analyzer/cnet/cnet-2.0.5.ebuild
+++ b/net-analyzer/cnet/cnet-2.0.5.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/cnet-2.0.5.ebuild,v 1.1 2003/08/01 19:48:23 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/cnet-2.0.5.ebuild,v 1.2 2003/12/08 21:54:57 rizzo Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Network simulation tool"
SRC_URI="http://www.csse.uwa.edu.au/cnet/${P}.tgz"
HOMEPAGE="http://www.csse.uwa.edu.au/cnet"
@@ -10,9 +9,10 @@ HOMEPAGE="http://www.csse.uwa.edu.au/cnet"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
DEPEND=">=dev-lang/tk-8.3.4"
-RDEPEND=""
+#RDEPEND=""
# unpacking the source
src_unpack() {
@@ -20,6 +20,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/cnet-2.0.5-gentoo.patch
+ sed -i.orig -e "s/^CFLAGS.*/CFLAGS=${CFLAGS}/" ${S}/src/Makefile.linux
}
src_install() {
@@ -29,5 +30,10 @@ src_install() {
mkdir -p ${D}/usr/{bin,lib,share}
mkdir -p ${D}/usr/share/man/man1
# install with make now
- make PREFIX=${D}/usr install
+ emake PREFIX=${D}/usr install || die
+
+ #install examples
+ DOCDESTTREE=EXAMPLES
+ dodir /usr/share/doc/${PF}/${DOCDESTTREE}
+ dodoc EXAMPLES/*
}