summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/scapy/scapy-2.1.0.ebuild')
-rw-r--r--net-analyzer/scapy/scapy-2.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-analyzer/scapy/scapy-2.1.0.ebuild b/net-analyzer/scapy/scapy-2.1.0.ebuild
new file mode 100644
index 000000000000..6dc27d337813
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/scapy-2.1.0.ebuild,v 1.1 2009/12/22 02:17:49 ikelos Exp $
+
+inherit distutils
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="http://www.secdev.org/projects/scapy/"
+SRC_URI="http://www.secdev.org/projects/scapy/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnuplot pyx crypt graphviz imagemagick visual tcpreplay"
+
+DEPEND="virtual/python"
+RDEPEND="net-analyzer/tcpdump
+ gnuplot? ( dev-python/gnuplot-py )
+ pyx? ( dev-python/pyx )
+ crypt? ( dev-python/pycrypto )
+ graphviz? ( media-gfx/graphviz )
+ imagemagick? ( media-gfx/imagemagick )
+ visual? ( dev-python/visual )
+ tcpreplay? ( net-analyzer/tcpreplay )"