summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/twoftpd/twoftpd-1.21-r1.ebuild')
-rw-r--r--net-ftp/twoftpd/twoftpd-1.21-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-ftp/twoftpd/twoftpd-1.21-r1.ebuild b/net-ftp/twoftpd/twoftpd-1.21-r1.ebuild
new file mode 100644
index 000000000000..ae2774f68354
--- /dev/null
+++ b/net-ftp/twoftpd/twoftpd-1.21-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/twoftpd/twoftpd-1.21-r1.ebuild,v 1.1 2008/11/13 13:00:27 bangert Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple secure efficient FTP server by Bruce Guenter"
+HOMEPAGE="http://untroubled.org/twoftpd/"
+SRC_URI="http://untroubled.org/twoftpd/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="breakrfc"
+
+DEPEND="virtual/libc
+ >=dev-libs/bglibs-1.026
+ >=net-libs/cvm-0.32"
+RDEPEND="sys-apps/ucspi-tcp
+ sys-process/daemontools
+ >=net-libs/cvm-0.32"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use breakrfc && epatch "${FILESDIR}"/${P}-disable-TELNET_IAC.patch
+}
+
+src_compile() {
+ echo "/usr/sbin" > conf-bin
+ echo "/usr/share/man" > conf-man
+ echo "$(tc-getCC) ${CFLAGS} -I/usr/include/bglibs" > conf-cc
+ echo "$(tc-getCC) -s -L/usr/lib/bglibs" > conf-ld
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/sbin
+ dodir /usr/share/man/man1
+
+ emake install install_prefix="${D}" || die "install failed"
+
+ dodoc ANNOUNCEMENT ChangeLog NEWS README TODO VERSION
+ dodoc twoftpd.run twoftpd-log.run
+}