summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/knock/knock-0.1.ebuild')
-rw-r--r--net-misc/knock/knock-0.1.ebuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/net-misc/knock/knock-0.1.ebuild b/net-misc/knock/knock-0.1.ebuild
index cadfb84fc080..eec0a73f3e1b 100644
--- a/net-misc/knock/knock-0.1.ebuild
+++ b/net-misc/knock/knock-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/knock/knock-0.1.ebuild,v 1.12 2005/03/14 17:49:52 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/knock/knock-0.1.ebuild,v 1.13 2005/07/30 18:07:29 swegener Exp $
inherit eutils
@@ -21,16 +21,11 @@ src_unpack() {
epatch ${FILESDIR}/knockd.conf.patch
}
-src_compile() {
- econf || die "could not configure"
- emake || die "emake failed"
-}
-
src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc README
dohtml doc/index.html
- insinto /etc/conf.d; newins ${FILESDIR}/knockd.confd knock
- exeinto /etc/init.d; newexe ${FILESDIR}/knockd.initd knock
+ newconfd ${FILESDIR}/knockd.confd knock
+ newinitd ${FILESDIR}/knockd.initd knock
}