summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/lapack-reference')
-rw-r--r--sci-libs/lapack-reference/ChangeLog7
-rw-r--r--sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild12
-rw-r--r--sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild10
-rw-r--r--sci-libs/lapack-reference/lapack-reference-3.2.1.ebuild12
4 files changed, 20 insertions, 21 deletions
diff --git a/sci-libs/lapack-reference/ChangeLog b/sci-libs/lapack-reference/ChangeLog
index c18ef9a1bac7..950d6ecf9642 100644
--- a/sci-libs/lapack-reference/ChangeLog
+++ b/sci-libs/lapack-reference/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/lapack-reference
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/ChangeLog,v 1.51 2010/10/02 20:49:51 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/ChangeLog,v 1.52 2010/12/16 14:33:46 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org>
+ lapack-reference-3.1.1-r1.ebuild, lapack-reference-3.2.1.ebuild,
+ lapack-reference-3.2.1-r1.ebuild:
+ Removal of fortran.eclass, #348851
02 Oct 2010; Fabian Groffen <grobian@gentoo.org>
lapack-reference-3.2.1-r1.ebuild:
diff --git a/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild b/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild
index 18c630813f89..420eb80a8e5f 100644
--- a/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild
+++ b/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild,v 1.20 2008/12/07 19:10:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.1.1-r1.ebuild,v 1.21 2010/12/16 14:33:46 jlec Exp $
-inherit eutils autotools flag-o-matic fortran multilib
+inherit eutils autotools flag-o-matic multilib toolchain-funcs
MyPN="${PN/-reference/}"
@@ -26,9 +26,7 @@ RDEPEND="virtual/blas
S="${WORKDIR}/${MyPN}-lite-${PV}"
pkg_setup() {
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- if [[ ${FORTRANC} == if* ]]; then
+ if [[ $(tc-getFC) == if* ]]; then
ewarn "Using Intel Fortran at your own risk"
export LDFLAGS="$(raw-ldflags)"
export NOOPT_FFLAGS=-O
@@ -44,7 +42,7 @@ src_unpack() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas):" \
diff --git a/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild b/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild
index e5bad2c031ab..3c25f2631094 100644
--- a/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild
+++ b/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild,v 1.2 2010/10/02 20:49:51 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.2.1-r1.ebuild,v 1.3 2010/12/16 14:33:46 jlec Exp $
EAPI="3"
-inherit eutils autotools flag-o-matic fortran multilib
+inherit eutils autotools flag-o-matic multilib toolchain-funcs
MyPN="${PN/-reference/}"
PATCH_V="3.2.1"
@@ -29,9 +29,7 @@ RDEPEND="virtual/blas
S="${WORKDIR}/${MyPN}-${PV}"
pkg_setup() {
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- if [[ ${FORTRANC} == if* ]]; then
+ if [[ $(tc-getFC) == if* ]]; then
ewarn "Using Intel Fortran at your own risk"
export LDFLAGS="$(raw-ldflags)"
export NOOPT_FFLAGS=-O
@@ -45,7 +43,7 @@ src_prepare() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas):" \
diff --git a/sci-libs/lapack-reference/lapack-reference-3.2.1.ebuild b/sci-libs/lapack-reference/lapack-reference-3.2.1.ebuild
index 02249ea201ea..2047f06747e8 100644
--- a/sci-libs/lapack-reference/lapack-reference-3.2.1.ebuild
+++ b/sci-libs/lapack-reference/lapack-reference-3.2.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.2.1.ebuild,v 1.2 2009/12/12 17:43:05 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-reference/lapack-reference-3.2.1.ebuild,v 1.3 2010/12/16 14:33:46 jlec Exp $
-inherit eutils autotools flag-o-matic fortran multilib
+inherit eutils autotools flag-o-matic multilib toolchain-funcs
MyPN="${PN/-reference/}"
PATCH_V="3.2.1"
@@ -27,9 +27,7 @@ RDEPEND="virtual/blas
S="${WORKDIR}/${MyPN}-${PV}"
pkg_setup() {
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- if [[ ${FORTRANC} == if* ]]; then
+ if [[ $(tc-getFC) == if* ]]; then
ewarn "Using Intel Fortran at your own risk"
export LDFLAGS="$(raw-ldflags)"
export NOOPT_FFLAGS=-O
@@ -45,7 +43,7 @@ src_unpack() {
eautoreconf
# set up the testing routines
- sed -e "s:g77:${FORTRANC}:" \
+ sed -e "s:g77:$(tc-getFC):" \
-e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas):" \
-e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas):" \
-e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas):" \