summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/getdata/ChangeLog7
-rw-r--r--sci-libs/getdata/getdata-0.6.3-r1.ebuild93
-rw-r--r--sci-libs/getdata/getdata-0.6.3.ebuild37
-rw-r--r--sci-libs/getdata/getdata-0.7.3.ebuild93
-rw-r--r--sci-libs/getdata/getdata-0.8.0.ebuild3
5 files changed, 8 insertions, 225 deletions
diff --git a/sci-libs/getdata/ChangeLog b/sci-libs/getdata/ChangeLog
index a136ebfd9922..5e539fe11474 100644
--- a/sci-libs/getdata/ChangeLog
+++ b/sci-libs/getdata/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/getdata
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/ChangeLog,v 1.10 2012/08/03 18:51:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/ChangeLog,v 1.11 2012/09/22 20:51:08 xarthisius Exp $
+
+ 22 Sep 2012; Kacper Kowalik <xarthisius@gentoo.org> -getdata-0.6.3-r1.ebuild,
+ -getdata-0.6.3.ebuild, -getdata-0.7.3.ebuild, getdata-0.8.0.ebuild:
+ Drop old, add missing dependency on virtual/fortran. Fixes bug #435930 by Ben
+ Longbons <b.r.longbons@gmail.com>
03 Aug 2012; SĂ©bastien Fabbro <bicatali@gentoo.org> getdata-0.8.0.ebuild,
metadata.xml:
diff --git a/sci-libs/getdata/getdata-0.6.3-r1.ebuild b/sci-libs/getdata/getdata-0.6.3-r1.ebuild
deleted file mode 100644
index 6b819d11b6fb..000000000000
--- a/sci-libs/getdata/getdata-0.6.3-r1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/getdata-0.6.3-r1.ebuild,v 1.3 2011/09/19 16:03:52 jlec Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-
-FORTRAN_STANDARD="95"
-
-inherit autotools fortran-2 python
-
-DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
-HOMEPAGE="http://getdata.sourceforge.net/"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bzip2 fortran lzma python static-libs"
-
-DEPEND="
- bzip2? ( app-arch/bzip2 )
- lzma? ( app-arch/xz-utils )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- use fortran && fortran-2_pkg_setup
-}
-
-src_prepare() {
- # Python bindings are built/tested/installed manually.
- sed -e "/PY_SUBDIR/s/python//" -i bindings/Makefile.am
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-idl \
- --without-libslim \
- --with-libz \
- --enable-shared \
- --docdir="${EPREFIX}/usr/share/doc/${P}" \
- $(use_enable fortran) \
- $(use_enable fortran fortran95) \
- $(use_enable python) \
- $(use_enable static-libs static) \
- $(use_with bzip2 libbz2) \
- $(use_with lzma liblzma)
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources bindings/python
- building() {
- sed "s:-lpython...:$(python_get_library --linker-option):g" -i Makefile || die
- emake \
- PYTHON_VERSION="$(python_get_version)" \
- NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
- PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
- }
- python_execute_function -s --source-dir bindings/python building
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYTHON_VERSION="$(python_get_version)" \
- NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
- PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
- PYTHON_VERSION="$(python_get_version)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)" \
- install
- if use static-libs; then
- find "${ED}/$(python_get_sitedir)" -type f -name "*.a" -delete || die
- fi
- }
- python_execute_function -s --source-dir bindings/python installation
- python_clean_installation_image
- fi
- dodoc AUTHORS ChangeLog NEWS README TODO || die "Installing docs failed"
-}
diff --git a/sci-libs/getdata/getdata-0.6.3.ebuild b/sci-libs/getdata/getdata-0.6.3.ebuild
deleted file mode 100644
index f5e4e7974582..000000000000
--- a/sci-libs/getdata/getdata-0.6.3.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/getdata-0.6.3.ebuild,v 1.2 2010/11/14 13:39:27 jlec Exp $
-
-EAPI=2
-
-DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
-HOMEPAGE="http://getdata.sourceforge.net/"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bzip2 lzma python"
-
-DEPEND="
- bzip2? ( app-arch/bzip2 )
- lzma? ( app-arch/xz-utils )
- python? ( dev-lang/python )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local myconf="\
- --disable-idl \
- --without-libslim \
- --with-libz \
- --docdir=/usr/share/doc/${P} \
- $(use_enable python) \
- $(use_with bzip2 libbz2) \
- $(use_with lzma liblzma)"
- econf ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die "Installing docs failed"
-}
diff --git a/sci-libs/getdata/getdata-0.7.3.ebuild b/sci-libs/getdata/getdata-0.7.3.ebuild
deleted file mode 100644
index 3329b7976dd7..000000000000
--- a/sci-libs/getdata/getdata-0.7.3.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/getdata-0.7.3.ebuild,v 1.2 2011/09/19 16:03:52 jlec Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
-
-FORTRAN_STANDARD="95"
-
-inherit autotools fortran-2 python
-
-DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
-HOMEPAGE="http://getdata.sourceforge.net/"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bzip2 fortran lzma python static-libs"
-
-DEPEND="
- bzip2? ( app-arch/bzip2 )
- lzma? ( app-arch/xz-utils )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- use fortran && fortran-2_pkg_setup
-}
-
-src_prepare() {
- # Python bindings are built/tested/installed manually.
- sed -e "/PY_SUBDIR/s/python//" -i bindings/Makefile.am
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-idl \
- --without-libslim \
- --with-libz \
- --enable-shared \
- --docdir="${EPREFIX}/usr/share/doc/${P}" \
- $(use_enable fortran) \
- $(use_enable fortran fortran95) \
- $(use_enable python) \
- $(use_enable static-libs static) \
- $(use_with bzip2 libbz2) \
- $(use_with lzma liblzma)
-}
-
-src_compile() {
- default
-
- if use python; then
- python_copy_sources bindings/python
- building() {
- sed "s:-lpython...:$(python_get_library --linker-option):g" -i Makefile || die
- emake \
- PYTHON_VERSION="$(python_get_version)" \
- NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
- PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
- }
- python_execute_function -s --source-dir bindings/python building
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- PYTHON_VERSION="$(python_get_version)" \
- NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
- PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
- PYTHON_VERSION="$(python_get_version)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)" \
- install
- if use static-libs; then
- find "${ED}/$(python_get_sitedir)" -type f -name "*.a" -delete || die
- fi
- }
- python_execute_function -s --source-dir bindings/python installation
- python_clean_installation_image
- fi
- dodoc AUTHORS ChangeLog NEWS README TODO || die "Installing docs failed"
-}
diff --git a/sci-libs/getdata/getdata-0.8.0.ebuild b/sci-libs/getdata/getdata-0.8.0.ebuild
index ac6070690c5d..ca6171f9a651 100644
--- a/sci-libs/getdata/getdata-0.8.0.ebuild
+++ b/sci-libs/getdata/getdata-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/getdata-0.8.0.ebuild,v 1.2 2012/08/03 18:51:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/getdata/getdata-0.8.0.ebuild,v 1.3 2012/09/22 20:51:08 xarthisius Exp $
EAPI=3
@@ -24,6 +24,7 @@ IUSE="bzip2 fortran lzma python perl static-libs"
DEPEND="
bzip2? ( app-arch/bzip2 )
lzma? ( app-arch/xz-utils )
+ fortran? ( virtual/fortran )
perl? ( dev-lang/perl )"
RDEPEND="${DEPEND}"