summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dmapi')
-rw-r--r--sys-apps/dmapi/dmapi-0.2.2.ebuild33
-rw-r--r--sys-apps/dmapi/files/digest-dmapi-0.2.21
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-0.2.2.ebuild b/sys-apps/dmapi/dmapi-0.2.2.ebuild
new file mode 100644
index 000000000000..1d38cb80662e
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-0.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-0.2.2.ebuild,v 1.1 2001/11/17 08:39:58 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs data management API library"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/latest/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" -e 's:-O1::' -e 's:-S \(.*\) $(PKG_.*_DIR)/\(.*$\):-S \1 \2:' include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ #let Steve Lord know that "install-dev" isn't mentioned in doc/INSTALL
+ make DESTDIR=${D} install install-dev || die
+}
diff --git a/sys-apps/dmapi/files/digest-dmapi-0.2.2 b/sys-apps/dmapi/files/digest-dmapi-0.2.2
new file mode 100644
index 000000000000..81300783adb5
--- /dev/null
+++ b/sys-apps/dmapi/files/digest-dmapi-0.2.2
@@ -0,0 +1 @@
+MD5 98a87591261b9f4baf3fcd209ab0f428 dmapi-0.2.2.src.tar.gz 57344