summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.6-r5.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r5.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r5.ebuild b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
index 7e630be1a983..cf96aaca8ab5 100644
--- a/sys-libs/glibc/glibc-2.3.6-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.27 2009/09/23 22:04:09 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.28 2009/12/10 01:31:25 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1014,7 +1014,7 @@ RDEPEND="nls? ( sys-devel/gettext )
selinux? ( !build? ( sys-libs/libselinux ) )"
if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- DEPEND="${DEPEND} ${CATEGORY}/gcc"
+ DEPEND="${DEPEND} !crosscompile_opts_headers-only? ( ${CATEGORY}/gcc )"
if [[ ${CATEGORY} == *-linux* ]] ; then
if [[ ${CATEGORY} == cross-mips* ]] ; then