summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/lsof/lsof-4.78.ebuild')
-rw-r--r--sys-process/lsof/lsof-4.78.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-process/lsof/lsof-4.78.ebuild b/sys-process/lsof/lsof-4.78.ebuild
index 9de5745d4346..5c436196b326 100644
--- a/sys-process/lsof/lsof-4.78.ebuild
+++ b/sys-process/lsof/lsof-4.78.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.78.ebuild,v 1.1 2007/05/12 11:39:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/lsof/lsof-4.78.ebuild,v 1.2 2007/05/18 14:18:44 uberlord Exp $
inherit eutils flag-o-matic fixheadtails toolchain-funcs
@@ -13,7 +13,7 @@ SRC_URI="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
LICENSE="lsof"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="static"
DEPEND=""
@@ -29,13 +29,16 @@ src_unpack() {
cd "${S}"
ht_fix_file Configure Customize
touch .neverInv
- epatch "${FILESDIR}"/4.73-answer-config.patch
+ epatch "${FILESDIR}/${P}"-answer-config.patch
+ epatch "${FILESDIR}/${P}"-freebsd.patch
}
src_compile() {
use static && append-ldflags -static
- ./Configure linux || die "configure failed"
+ local target="linux"
+ use kernel_FreeBSD && target=freebsd
+ ./Configure ${target} || die "configure failed"
# Make sure we use proper toolchain
sed -i \