summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/listres')
-rw-r--r--x11-apps/listres/ChangeLog10
-rw-r--r--x11-apps/listres/Manifest2
-rw-r--r--x11-apps/listres/files/digest-listres-0.99.01
-rw-r--r--x11-apps/listres/listres-0.99.0.ebuild25
4 files changed, 38 insertions, 0 deletions
diff --git a/x11-apps/listres/ChangeLog b/x11-apps/listres/ChangeLog
new file mode 100644
index 000000000000..414deb5487de
--- /dev/null
+++ b/x11-apps/listres/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-apps/listres
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/listres/ChangeLog,v 1.1 2005/08/08 06:28:09 spyderous Exp $
+
+*listres-0.99.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +listres-0.99.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-apps/listres/Manifest b/x11-apps/listres/Manifest
new file mode 100644
index 000000000000..052bc0d3a56f
--- /dev/null
+++ b/x11-apps/listres/Manifest
@@ -0,0 +1,2 @@
+MD5 7320db59284faf6f0b6e09a3843cad88 listres-0.99.0.ebuild 544
+MD5 60c8277df82dd59b74e292aba08e911b files/digest-listres-0.99.0 66
diff --git a/x11-apps/listres/files/digest-listres-0.99.0 b/x11-apps/listres/files/digest-listres-0.99.0
new file mode 100644
index 000000000000..e66d139e297b
--- /dev/null
+++ b/x11-apps/listres/files/digest-listres-0.99.0
@@ -0,0 +1 @@
+MD5 8a14a509d39d1520e04095c7d0ee45ab listres-0.99.0.tar.bz2 53546
diff --git a/x11-apps/listres/listres-0.99.0.ebuild b/x11-apps/listres/listres-0.99.0.ebuild
new file mode 100644
index 000000000000..fba0eb4c8295
--- /dev/null
+++ b/x11-apps/listres/listres-0.99.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/listres/listres-0.99.0.ebuild,v 1.1 2005/08/08 06:28:09 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org listres application"
+KEYWORDS="~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}